<!DOCTYPE HTML>
<html lang="en-US">
<head>
	<meta charset="UTF-8">
<script>
var gform;gform||(document.addEventListener("gform_main_scripts_loaded",function(){gform.scriptsLoaded=!0}),window.addEventListener("DOMContentLoaded",function(){gform.domLoaded=!0}),gform={domLoaded:!1,scriptsLoaded:!1,initializeOnLoaded:function(o){gform.domLoaded&&gform.scriptsLoaded?o():!gform.domLoaded&&gform.scriptsLoaded?window.addEventListener("DOMContentLoaded",o):document.addEventListener("gform_main_scripts_loaded",o)},hooks:{action:{},filter:{}},addAction:function(o,n,r,t){gform.addHook("action",o,n,r,t)},addFilter:function(o,n,r,t){gform.addHook("filter",o,n,r,t)},doAction:function(o){gform.doHook("action",o,arguments)},applyFilters:function(o){return gform.doHook("filter",o,arguments)},removeAction:function(o,n){gform.removeHook("action",o,n)},removeFilter:function(o,n,r){gform.removeHook("filter",o,n,r)},addHook:function(o,n,r,t,i){null==gform.hooks[o][n]&&(gform.hooks[o][n]=[]);var e=gform.hooks[o][n];null==i&&(i=n+"_"+e.length),gform.hooks[o][n].push({tag:i,callable:r,priority:t=null==t?10:t})},doHook:function(n,o,r){var t;if(r=Array.prototype.slice.call(r,1),null!=gform.hooks[n][o]&&((o=gform.hooks[n][o]).sort(function(o,n){return o.priority-n.priority}),o.forEach(function(o){"function"!=typeof(t=o.callable)&&(t=window[t]),"action"==n?t.apply(null,r):r[0]=t.apply(null,r)})),"filter"==n)return r[0]},removeHook:function(o,n,t,i){var r;null!=gform.hooks[o][n]&&(r=(r=gform.hooks[o][n]).filter(function(o,n,r){return!!(null!=i&&i!=o.tag||null!=t&&t!=o.priority)}),gform.hooks[o][n]=r)}});
</script>

	<title>Columnstore Indexes are Finally Sorted in SQL Server 2022. - Brent Ozar Unlimited®</title>
<meta name='robots' content='max-image-preview:large' />

<!-- This site is optimized with the Yoast SEO Premium plugin v12.2 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="robots" content="max-snippet:-1, max-image-preview:large, max-video-preview:-1"/>
<link rel="canonical" href="https://www.brentozar.com/archive/2022/07/columnstore-indexes-are-finally-sorted-in-sql-server-2022/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Columnstore Indexes are Finally Sorted in SQL Server 2022. - Brent Ozar Unlimited®" />
<meta property="og:description" content="There&#8217;s a widespread misconception that SQL Server&#8217;s columnstore indexes are like an index on every column. I debunk that myth in the first 30 minutes of my Fundamentals of Columnstore class, where I explain that a better way to think of them is that your table is broken up into groups of rows (1M rows..." />
<meta property="og:url" content="https://www.brentozar.com/archive/2022/07/columnstore-indexes-are-finally-sorted-in-sql-server-2022/" />
<meta property="og:site_name" content="Brent Ozar Unlimited®" />
<meta property="article:publisher" content="https://www.facebook.com/BrentOzarUnlimited" />
<meta property="article:author" content="https://www.facebook.com/brentozar" />
<meta property="article:section" content="Columnstore Indexes" />
<meta property="article:published_time" content="2022-07-05T13:15:35+00:00" />
<meta property="article:modified_time" content="2022-07-12T06:33:37+00:00" />
<meta property="og:updated_time" content="2022-07-12T06:33:37+00:00" />
<meta property="og:image" content="https://www.brentozar.com/wp-content/uploads/2022/07/unordered_rowgroups.jpg" />
<meta property="og:image:secure_url" content="https://www.brentozar.com/wp-content/uploads/2022/07/unordered_rowgroups.jpg" />
<meta property="og:image:width" content="754" />
<meta property="og:image:height" content="377" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="There&#8217;s a widespread misconception that SQL Server&#8217;s columnstore indexes are like an index on every column. I debunk that myth in the first 30 minutes of my Fundamentals of Columnstore class, where I explain that a better way to think of them is that your table is broken up into groups of rows (1M rows..." />
<meta name="twitter:title" content="Columnstore Indexes are Finally Sorted in SQL Server 2022. - Brent Ozar Unlimited®" />
<meta name="twitter:site" content="@BrentOzarULTD" />
<meta name="twitter:image" content="https://www.brentozar.com/wp-content/uploads/2022/07/unordered_rowgroups.jpg" />
<meta name="twitter:creator" content="@BrentO" />
<script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://www.brentozar.com/#organization","name":"Brent Ozar Unlimited","url":"https://www.brentozar.com/","sameAs":["https://www.facebook.com/BrentOzarUnlimited","https://www.instagram.com/brent_ozar_unlimited/","https://www.linkedin.com/company/brent-ozar-unlimited","http://youtube.com/user/BrentOzar/","https://twitter.com/BrentOzarULTD"],"logo":{"@type":"ImageObject","@id":"https://www.brentozar.com/#logo","url":"https://www.brentozar.com/wp-content/uploads/2015/04/stacked-with-text-995-x-589.png","width":995,"height":589,"caption":"Brent Ozar Unlimited"},"image":{"@id":"https://www.brentozar.com/#logo"}},{"@type":"WebSite","@id":"https://www.brentozar.com/#website","url":"https://www.brentozar.com/","name":"Brent Ozar Unlimited\u00ae","publisher":{"@id":"https://www.brentozar.com/#organization"},"potentialAction":{"@type":"SearchAction","target":"https://www.brentozar.com/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"ImageObject","@id":"https://www.brentozar.com/archive/2022/07/columnstore-indexes-are-finally-sorted-in-sql-server-2022/#primaryimage","url":"https://www.brentozar.com/wp-content/uploads/2022/07/unordered_rowgroups.jpg","width":754,"height":377},{"@type":"WebPage","@id":"https://www.brentozar.com/archive/2022/07/columnstore-indexes-are-finally-sorted-in-sql-server-2022/#webpage","url":"https://www.brentozar.com/archive/2022/07/columnstore-indexes-are-finally-sorted-in-sql-server-2022/","inLanguage":"en-US","name":"Columnstore Indexes are Finally Sorted in SQL Server 2022. - Brent Ozar Unlimited\u00ae","isPartOf":{"@id":"https://www.brentozar.com/#website"},"primaryImageOfPage":{"@id":"https://www.brentozar.com/archive/2022/07/columnstore-indexes-are-finally-sorted-in-sql-server-2022/#primaryimage"},"datePublished":"2022-07-05T13:15:35+00:00","dateModified":"2022-07-12T06:33:37+00:00"},{"@type":"Article","@id":"https://www.brentozar.com/archive/2022/07/columnstore-indexes-are-finally-sorted-in-sql-server-2022/#article","isPartOf":{"@id":"https://www.brentozar.com/archive/2022/07/columnstore-indexes-are-finally-sorted-in-sql-server-2022/#webpage"},"author":{"@id":"https://www.brentozar.com/#/schema/person/ae2a5fb417ca19d8392f78318ea1edbe"},"headline":"Columnstore Indexes are Finally Sorted in SQL Server 2022.","datePublished":"2022-07-05T13:15:35+00:00","dateModified":"2022-07-12T06:33:37+00:00","commentCount":20,"mainEntityOfPage":{"@id":"https://www.brentozar.com/archive/2022/07/columnstore-indexes-are-finally-sorted-in-sql-server-2022/#webpage"},"publisher":{"@id":"https://www.brentozar.com/#organization"},"image":{"@id":"https://www.brentozar.com/archive/2022/07/columnstore-indexes-are-finally-sorted-in-sql-server-2022/#primaryimage"},"articleSection":"Columnstore Indexes"},{"@type":["Person"],"@id":"https://www.brentozar.com/#/schema/person/ae2a5fb417ca19d8392f78318ea1edbe","name":"Brent Ozar","image":{"@type":"ImageObject","@id":"https://www.brentozar.com/#authorlogo","url":"https://secure.gravatar.com/avatar/77f776c2eaf0cc691e8a0880bb8a191f?s=96&d=wavatar&r=r","caption":"Brent Ozar"},"description":"I make Microsoft SQL Server go faster. I love teaching, travel, cars, and laughing. I'm based out of Las Vegas. He/him.","sameAs":["https://www.facebook.com/brentozar","https://twitter.com/BrentO"]}]}</script>
<!-- / Yoast SEO Premium plugin. -->

<script type='application/javascript'>console.log('PixelYourSite PRO version 9.2.0');</script>
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel="alternate" type="application/rss+xml" title="Brent Ozar Unlimited® &raquo; Feed" href="https://www.brentozar.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Brent Ozar Unlimited® &raquo; Comments Feed" href="https://www.brentozar.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Brent Ozar Unlimited® &raquo; Columnstore Indexes are Finally Sorted in SQL Server 2022. Comments Feed" href="https://www.brentozar.com/archive/2022/07/columnstore-indexes-are-finally-sorted-in-sql-server-2022/feed/" />
<meta name="viewport" content="width=device-width, initial-scale=1">
<meta name="SKYPE_TOOLBAR" content="SKYPE_TOOLBAR_PARSER_COMPATIBLE">
<meta name="theme-color" content="#f5f5f5">
<link rel='stylesheet' id='crayon-theme-classic-css'  href='https://www.brentozar.com/wp-content/plugins/urvanov-syntax-highlighter/themes/classic/classic.css?ver=2.8.27' media='all' />
<link rel='stylesheet' id='crayon-font-monaco-css'  href='https://www.brentozar.com/wp-content/plugins/urvanov-syntax-highlighter/fonts/monaco.css?ver=2.8.27' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://www.brentozar.com/wp-includes/css/dist/block-library/style.min.css?ver=6.0.1' media='all' />
<link rel='stylesheet' id='wc-blocks-vendors-style-css'  href='https://www.brentozar.com/wp-content/plugins/woocommerce/packages/woocommerce-blocks/build/wc-blocks-vendors-style.css?ver=7.8.3' media='all' />
<link rel='stylesheet' id='wc-blocks-style-css'  href='https://www.brentozar.com/wp-content/plugins/woocommerce/packages/woocommerce-blocks/build/wc-blocks-style.css?ver=7.8.3' media='all' />
<link rel='stylesheet' id='wc-memberships-blocks-css'  href='https://www.brentozar.com/wp-content/plugins/woocommerce-memberships/assets/css/blocks/wc-memberships-blocks.min.css?ver=1.23.0' media='all' />
<style id='global-styles-inline-css'>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</style>
<link rel='stylesheet' id='ccchildpagescss-css'  href='https://www.brentozar.com/wp-content/plugins/cc-child-pages/includes/css/styles.css?ver=1.40' media='all' />
<link rel='stylesheet' id='ccchildpagesskincss-css'  href='https://www.brentozar.com/wp-content/plugins/cc-child-pages/includes/css/skins.css?ver=1.40' media='all' />
<!--[if lt IE 8]>
<link rel='stylesheet' id='ccchildpagesiecss-css'  href='https://www.brentozar.com/wp-content/plugins/cc-child-pages/includes/css/styles.ie.css?ver=1.40' media='all' />
<![endif]-->
<style id='woocommerce-inline-inline-css'>
.woocommerce form .form-row .required { visibility: visible; }
</style>
<link rel='stylesheet' id='metorik-css-css'  href='https://www.brentozar.com/wp-content/plugins/metorik-helper/assets/css/metorik.css?ver=1.5.2' media='all' />
<link rel='stylesheet' id='wc-memberships-frontend-css'  href='https://www.brentozar.com/wp-content/plugins/woocommerce-memberships/assets/css/frontend/wc-memberships-frontend.min.css?ver=1.23.0' media='all' />
<link rel='stylesheet' id='us-fonts-css'  href='https://fonts.googleapis.com/css?family=Questrial%3A400%7COpen+Sans%3A400%2C400italic%2C700&#038;display=swap&#038;ver=6.0.1' media='all' />
<link rel='stylesheet' id='wc-pb-checkout-blocks-css'  href='https://www.brentozar.com/wp-content/plugins/woocommerce-product-bundles/assets/css/frontend/checkout-blocks.css?ver=6.16.0' media='all' />
<link rel='stylesheet' id='us-theme-css'  href='https://www.brentozar.com/wp-content/uploads/us-assets/www.brentozar.com.css?ver=1d2f895e' media='all' />
<link rel='stylesheet' id='theme-style-css'  href='https://www.brentozar.com/wp-content/themes/Impreza-child/style.css?ver=8.8.2' media='all' />
<link rel='stylesheet' id='bsf-Defaults-css'  href='https://www.brentozar.com/wp-content/uploads/smile_fonts/Defaults/Defaults.css?ver=3.19.11' media='all' />
<link rel='stylesheet' id='wc-bundle-style-css'  href='https://www.brentozar.com/wp-content/plugins/woocommerce-product-bundles/assets/css/frontend/woocommerce.css?ver=6.16.0' media='all' />
<script src='https://www.brentozar.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script>
<script src='https://www.brentozar.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<script id='jquery-js-after'>

					function optimocha_getCookie(name) {
						var v = document.cookie.match("(^|;) ?" + name + "=([^;]*)(;|$)");
						return v ? v[2] : null;
					}

					function optimocha_check_wc_cart_script() {
					var cart_src = "https://www.brentozar.com/wp-content/plugins/woocommerce/assets/js/frontend/cart-fragments.min.js";
					var script_id = "optimocha_loaded_wc_cart_fragments";

						if( document.getElementById(script_id) !== null ) {
							return false;
						}

						if( optimocha_getCookie("woocommerce_cart_hash") ) {
							var script = document.createElement("script");
							script.id = script_id;
							script.src = cart_src;
							script.async = true;
							document.head.appendChild(script);
						}
					}

					optimocha_check_wc_cart_script();
					document.addEventListener("click", function(){setTimeout(optimocha_check_wc_cart_script,1000);});
					
</script>
<script src='https://www.brentozar.com/wp-content/plugins/woocommerce/assets/js/js-cookie/js.cookie.min.js?ver=2.1.4-wc.6.7.0' id='js-cookie-js'></script>
<script src='https://www.brentozar.com/wp-content/plugins/pixelyoursite-pro/dist/scripts/jquery.bind-first-0.2.3.min.js?ver=6.0.1' id='jquery-bind-first-js'></script>
<script src='https://www.brentozar.com/wp-content/plugins/pixelyoursite-pro/dist/scripts/vimeo.min.js?ver=6.0.1' id='vimeo-js'></script>
<script id='pys-js-extra'>
var pysOptions = {"staticEvents":{"facebook":{"init_event":[{"delay":0,"type":"static","name":"PageView","pixelIds":["277915446177659"],"params":{"post_category":"Columnstore Indexes","page_title":"Columnstore Indexes are Finally Sorted in SQL Server 2022.","post_type":"post","post_id":348666,"plugin":"PixelYourSite","event_url":"www.brentozar.com\/archive\/2022\/07\/columnstore-indexes-are-finally-sorted-in-sql-server-2022\/","user_role":"guest"},"e_id":"init_event","ids":[],"hasTimeWindow":false,"timeWindow":0,"eventID":"","woo_order":"","edd_order":""}]}},"dynamicEvents":[],"triggerEvents":[],"triggerEventTypes":[],"facebook":{"pixelIds":["277915446177659"],"advancedMatching":[],"removeMetadata":false,"wooVariableAsSimple":false,"serverApiEnabled":false,"ajaxForServerEvent":true,"wooCRSendFromServer":false,"send_external_id":true},"ga":{"trackingIds":["UA-122681213-1"],"enhanceLinkAttr":false,"anonimizeIP":false,"retargetingLogic":"ecomm","crossDomainEnabled":false,"crossDomainAcceptIncoming":false,"crossDomainDomains":[],"wooVariableAsSimple":false,"isDebugEnabled":[""],"disableAdvertisingFeatures":false,"disableAdvertisingPersonalization":false},"google_ads":{"conversion_ids":["AW-1038829351"],"enhanced_conversion":[],"wooVariableAsSimple":false,"user_data":[]},"debug":"","siteUrl":"https:\/\/www.brentozar.com","ajaxUrl":"https:\/\/www.brentozar.com\/wp-admin\/admin-ajax.php","trackUTMs":"1","trackTrafficSource":"1","user_id":"0","enable_lading_page_param":"1","cookie_duration":"7","enable_event_day_param":"1","enable_event_month_param":"1","enable_event_time_param":"1","enable_remove_target_url_param":"1","enable_remove_download_url_param":"1","visit_data_model":"first_visit","gdpr":{"ajax_enabled":false,"all_disabled_by_api":false,"facebook_disabled_by_api":false,"tiktok_disabled_by_api":false,"analytics_disabled_by_api":false,"google_ads_disabled_by_api":false,"pinterest_disabled_by_api":false,"bing_disabled_by_api":false,"facebook_prior_consent_enabled":true,"tiktok_prior_consent_enabled":true,"analytics_prior_consent_enabled":true,"google_ads_prior_consent_enabled":true,"pinterest_prior_consent_enabled":true,"bing_prior_consent_enabled":true,"cookiebot_integration_enabled":false,"cookiebot_facebook_consent_category":"marketing","cookiebot_analytics_consent_category":"statistics","cookiebot_google_ads_consent_category":"marketing","cookiebot_pinterest_consent_category":"marketing","cookiebot_bing_consent_category":"marketing","cookie_notice_integration_enabled":false,"cookie_law_info_integration_enabled":false,"real_cookie_banner_integration_enabled":false,"consent_magic_integration_enabled":false},"automatic":{"enable_youtube":true,"enable_vimeo":true,"enable_video":true},"woo":{"enabled":true,"addToCartOnButtonEnabled":true,"addToCartOnButtonValueEnabled":true,"addToCartOnButtonValueOption":"price","woo_purchase_on_transaction":true,"singleProductId":null,"affiliateEnabled":false,"removeFromCartSelector":"form.woocommerce-cart-form .remove","addToCartCatchMethod":"add_cart_hook","is_order_received_page":false,"containOrderId":false,"affiliateEventName":"Lead"},"edd":{"enabled":false}};
</script>
<script src='https://www.brentozar.com/wp-content/plugins/pixelyoursite-pro/dist/scripts/public.js?ver=9.2.0' id='pys-js'></script>
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.brentozar.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.brentozar.com/wp-includes/wlwmanifest.xml" /> 
<link rel='shortlink' href='https://www.brentozar.com/?p=348666' />
<link rel="alternate" type="application/json+oembed" href="https://www.brentozar.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.brentozar.com%2Farchive%2F2022%2F07%2Fcolumnstore-indexes-are-finally-sorted-in-sql-server-2022%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.brentozar.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.brentozar.com%2Farchive%2F2022%2F07%2Fcolumnstore-indexes-are-finally-sorted-in-sql-server-2022%2F&#038;format=xml" />
<style type="text/css">dd ul.bulleted {  float:none;clear:both; }</style>		<script>
			if ( ! /Android|webOS|iPhone|iPad|iPod|BlackBerry|IEMobile|Opera Mini/i.test( navigator.userAgent ) ) {
				var root = document.getElementsByTagName( 'html' )[ 0 ]
				root.className += " no-touch";
			}
		</script>
			<noscript><style>.woocommerce-product-gallery{ opacity: 1 !important; }</style></noscript>
	<meta name="generator" content="Powered by WPBakery Page Builder - drag and drop page builder for WordPress."/>
<link rel="icon" href="https://www.brentozar.com/wp-content/uploads/2015/08/cropped-Brent_Ozar_Unlimited-32x32.jpg" sizes="32x32" />
<link rel="icon" href="https://www.brentozar.com/wp-content/uploads/2015/08/cropped-Brent_Ozar_Unlimited-192x192.jpg" sizes="192x192" />
<link rel="apple-touch-icon" href="https://www.brentozar.com/wp-content/uploads/2015/08/cropped-Brent_Ozar_Unlimited-180x180.jpg" />
<meta name="msapplication-TileImage" content="https://www.brentozar.com/wp-content/uploads/2015/08/cropped-Brent_Ozar_Unlimited-270x270.jpg" />
<noscript><style> .wpb_animate_when_almost_visible { opacity: 1; }</style></noscript>		<style id="us-icon-fonts">@font-face{font-display:block;font-style:normal;font-family:"fontawesome";font-weight:900;src:url("https://www.brentozar.com/wp-content/themes/Impreza/fonts/fa-solid-900.woff2?ver=8.8.2") format("woff2"),url("https://www.brentozar.com/wp-content/themes/Impreza/fonts/fa-solid-900.woff?ver=8.8.2") format("woff")}.fas{font-family:"fontawesome";font-weight:900}@font-face{font-display:block;font-style:normal;font-family:"fontawesome";font-weight:400;src:url("https://www.brentozar.com/wp-content/themes/Impreza/fonts/fa-regular-400.woff2?ver=8.8.2") format("woff2"),url("https://www.brentozar.com/wp-content/themes/Impreza/fonts/fa-regular-400.woff?ver=8.8.2") format("woff")}.far{font-family:"fontawesome";font-weight:400}@font-face{font-display:block;font-style:normal;font-family:"fontawesome";font-weight:300;src:url("https://www.brentozar.com/wp-content/themes/Impreza/fonts/fa-light-300.woff2?ver=8.8.2") format("woff2"),url("https://www.brentozar.com/wp-content/themes/Impreza/fonts/fa-light-300.woff?ver=8.8.2") format("woff")}.fal{font-family:"fontawesome";font-weight:300}@font-face{font-display:block;font-style:normal;font-family:"Font Awesome 5 Duotone";font-weight:900;src:url("https://www.brentozar.com/wp-content/themes/Impreza/fonts/fa-duotone-900.woff2?ver=8.8.2") format("woff2"),url("https://www.brentozar.com/wp-content/themes/Impreza/fonts/fa-duotone-900.woff?ver=8.8.2") format("woff")}.fad{font-family:"Font Awesome 5 Duotone";font-weight:900}.fad{position:relative}.fad:before{position:absolute}.fad:after{opacity:0.4}@font-face{font-display:block;font-style:normal;font-family:"Font Awesome 5 Brands";font-weight:400;src:url("https://www.brentozar.com/wp-content/themes/Impreza/fonts/fa-brands-400.woff2?ver=8.8.2") format("woff2"),url("https://www.brentozar.com/wp-content/themes/Impreza/fonts/fa-brands-400.woff?ver=8.8.2") format("woff")}.fab{font-family:"Font Awesome 5 Brands";font-weight:400}@font-face{font-display:block;font-style:normal;font-family:"Material Icons";font-weight:400;src:url("https://www.brentozar.com/wp-content/themes/Impreza/fonts/material-icons.woff2?ver=8.8.2") format("woff2"),url("https://www.brentozar.com/wp-content/themes/Impreza/fonts/material-icons.woff?ver=8.8.2") format("woff")}.material-icons{font-family:"Material Icons";font-weight:400}</style>
				<style id="us-header-css">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</style>
		<link rel="apple-touch-icon" sizes="180x180" href="/apple-touch-icon.png">
<link rel="icon" type="image/png" sizes="32x32" href="/favicon-32x32.png">
<link rel="icon" type="image/png" sizes="16x16" href="/favicon-16x16.png">
<link rel="manifest" href="/site.webmanifest">
<link rel="mask-icon" href="/safari-pinned-tab.svg" color="#ef4135">
<meta name="msapplication-TileColor" content="#00aba9">
<meta name="theme-color" content="#ffffff"><style id="us-design-options-css">.us_custom_e11ab399{padding-bottom:0px!important}.us_custom_e2aee182{font-family:var(--font-h1)!important}.us_custom_ea2be81a{font-size:0.9rem!important}</style></head>
<body class="post-template-default single single-post postid-348666 single-format-standard wp-embed-responsive l-body Impreza_8.8.2 us-core_8.8.2 header_hor headerinpos_top state_default theme-Impreza woocommerce-no-js us-woo-cart_compact wpb-js-composer js-comp-ver-6.9.0 vc_responsive" itemscope itemtype="https://schema.org/WebPage">
<svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-dark-grayscale"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0 0.498039215686" /><feFuncG type="table" tableValues="0 0.498039215686" /><feFuncB type="table" tableValues="0 0.498039215686" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-grayscale"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0 1" /><feFuncG type="table" tableValues="0 1" /><feFuncB type="table" tableValues="0 1" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-purple-yellow"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0.549019607843 0.988235294118" /><feFuncG type="table" tableValues="0 1" /><feFuncB type="table" tableValues="0.717647058824 0.254901960784" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-blue-red"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0 1" /><feFuncG type="table" tableValues="0 0.278431372549" /><feFuncB type="table" tableValues="0.592156862745 0.278431372549" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-midnight"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0 0" /><feFuncG type="table" tableValues="0 0.647058823529" /><feFuncB type="table" tableValues="0 1" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-magenta-yellow"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0.780392156863 1" /><feFuncG type="table" tableValues="0 0.949019607843" /><feFuncB type="table" tableValues="0.352941176471 0.470588235294" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-purple-green"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0.650980392157 0.403921568627" /><feFuncG type="table" tableValues="0 1" /><feFuncB type="table" tableValues="0.447058823529 0.4" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-blue-orange"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0.0980392156863 1" /><feFuncG type="table" tableValues="0 0.662745098039" /><feFuncB type="table" tableValues="0.847058823529 0.419607843137" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg>
<div class="l-canvas type_wide">
	<header id="page-header" class="l-header pos_fixed shadow_thin bg_solid with_bgimg id_75990" itemscope itemtype="https://schema.org/WPHeader"><div class="l-subheader at_top"><div class="l-subheader-h"><div class="l-subheader-cell at_left"></div><div class="l-subheader-cell at_center"></div><div class="l-subheader-cell at_right"><div class="w-search ush_search_1 elm_in_header layout_fullwidth"><a class="w-search-open" aria-label="Search" href="#"><i class="fas fa-search"></i></a><div class="w-search-form"><form class="w-form-row for_text" action="https://www.brentozar.com/" method="get"><div class="w-form-row-field"><input type="text" name="s" id="us_form_search_s" placeholder="Search" aria-label="Search" value/></div><button aria-label="Close" class="w-search-close" type="button"></button></form></div></div><nav class="w-nav type_desktop ush_menu_2 height_full dropdown_height m_align_left m_layout_dropdown" itemscope itemtype="https://schema.org/SiteNavigationElement"><a class="w-nav-control" aria-label="Menu" href="#"><div class="w-nav-icon"><div></div></div></a><ul class="w-nav-list level_1 hide_for_mobiles hover_simple"><li id="menu-item-326876" class="menu-item menu-item-type-custom menu-item-object-custom w-nav-item level_1 menu-item-326876"><a class="w-nav-anchor level_1" href="https://www.brentozar.com/log-in/"><span class="w-nav-title">Log In</span><span class="w-nav-arrow"></span></a></li><li id="menu-item-116345" class="menu-item menu-item-type-custom menu-item-object-custom w-nav-item level_1 menu-item-116345"><a class="w-nav-anchor level_1" href="https://www.brentozar.com/contact/"><span class="w-nav-title">Contact Brent</span><span class="w-nav-arrow"></span></a></li><li class="w-nav-close"></li></ul><div class="w-nav-options hidden" onclick='return {&quot;mobileWidth&quot;:900,&quot;mobileBehavior&quot;:1}'></div></nav><div class="w-cart dropdown_height ush_cart_1 height_full empty"><div class="w-cart-h"><a class="w-cart-link" href="https://www.brentozar.com/cart/" aria-label="Cart"><span class="w-cart-icon"><i class="fas fa-shopping-cart"></i><span class="w-cart-quantity" style="background:#777777;color:#ffffff;"></span></span></a><div class="w-cart-notification"><div><span class="product-name">Product</span> has been added to your cart.</div></div><div class="w-cart-dropdown"><div class="widget woocommerce widget_shopping_cart"><div class="widget_shopping_cart_content"></div></div></div></div></div><div class="w-socials ush_socials_1 color_brand shape_square style_default hover_none"><div class="w-socials-list"><div class="w-socials-item youtube"><a class="w-socials-item-link" href="https://www.youtube.com/c/BrentOzarUnlimited" target="_blank" rel="noopener nofollow" title="YouTube" aria-label="YouTube"><span class="w-socials-item-link-hover"></span><i class="fab fa-youtube"></i></a></div><div class="w-socials-item linkedin"><a class="w-socials-item-link" href="https://www.linkedin.com/in/brentozar/" target="_blank" rel="noopener nofollow" title="LinkedIn" aria-label="LinkedIn"><span class="w-socials-item-link-hover"></span><i class="fab fa-linkedin"></i></a></div><div class="w-socials-item facebook"><a class="w-socials-item-link" href="https://www.facebook.com/brentozar" target="_blank" rel="noopener nofollow" title="Facebook" aria-label="Facebook"><span class="w-socials-item-link-hover"></span><i class="fab fa-facebook"></i></a></div><div class="w-socials-item twitch"><a class="w-socials-item-link" href="https://www.twitch.tv/brentozar" target="_blank" rel="noopener nofollow" title="Twitch" aria-label="Twitch"><span class="w-socials-item-link-hover"></span><i class="fab fa-twitch"></i></a></div><div class="w-socials-item github"><a class="w-socials-item-link" href="https://github.com/BrentOzarULTD" target="_blank" rel="noopener nofollow" title="GitHub" aria-label="GitHub"><span class="w-socials-item-link-hover"></span><i class="fab fa-github"></i></a></div><div class="w-socials-item twitter"><a class="w-socials-item-link" href="https://twitter.com/BrentO" target="_blank" rel="noopener nofollow" title="Twitter" aria-label="Twitter"><span class="w-socials-item-link-hover"></span><i class="fab fa-twitter"></i></a></div></div></div></div></div></div><div class="l-subheader at_middle width_full"><div class="l-subheader-h"><div class="l-subheader-cell at_left"><div class="w-image ush_image_1"><a href="https://www.brentozar.com/" aria-label="Link" class="w-image-h"><img width="254" height="72" src="https://www.brentozar.com/wp-content/uploads/2016/09/Brent_Ozar_Unlimited_201609.png" class="attachment-large size-large" alt="" loading="lazy" srcset="https://www.brentozar.com/wp-content/uploads/2016/09/Brent_Ozar_Unlimited_201609.png 254w, https://www.brentozar.com/wp-content/uploads/2016/09/Brent_Ozar_Unlimited_201609-250x72.png 250w" sizes="(max-width: 254px) 100vw, 254px" /></a></div></div><div class="l-subheader-cell at_center"><nav class="w-nav type_desktop ush_menu_1 height_full dropdown_height m_align_left m_layout_dropdown" itemscope itemtype="https://schema.org/SiteNavigationElement"><a class="w-nav-control" aria-label="Menu" href="#"><div class="w-nav-icon"><div></div></div></a><ul class="w-nav-list level_1 hide_for_mobiles hover_simple"><li id="menu-item-25018" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children w-nav-item level_1 menu-item-25018"><a class="w-nav-anchor level_1" href="https://www.brentozar.com/sql-critical-care/"><span class="w-nav-title">Consulting</span><span class="w-nav-arrow"></span></a><ul class="w-nav-list level_2"><li id="menu-item-343471" class="menu-item menu-item-type-post_type menu-item-object-page w-nav-item level_2 menu-item-343471"><a class="w-nav-anchor level_2" href="https://www.brentozar.com/sql/sql-server-performance-tuning/"><span class="w-nav-title">Performance Tuning</span><span class="w-nav-arrow"></span></a></li><li id="menu-item-343470" class="menu-item menu-item-type-post_type menu-item-object-page w-nav-item level_2 menu-item-343470"><a class="w-nav-anchor level_2" href="https://www.brentozar.com/remote-dba-services-for-microsoft-sql-server/"><span class="w-nav-title">Remote DBA Services</span><span class="w-nav-arrow"></span></a></li><li id="menu-item-343474" class="menu-item menu-item-type-post_type menu-item-object-page w-nav-item level_2 menu-item-343474"><a class="w-nav-anchor level_2" href="https://www.brentozar.com/remote-dba-services-for-microsoft-sql-server/sql-server-upgrades-and-migrations/"><span class="w-nav-title">Upgrades and Migrations</span><span class="w-nav-arrow"></span></a></li><li id="menu-item-344269" class="menu-item menu-item-type-custom menu-item-object-custom w-nav-item level_2 menu-item-344269"><a class="w-nav-anchor level_2" href="https://training.brentozar.com/p/the-consultant-toolkit"><span class="w-nav-title">Consultant Toolkit</span><span class="w-nav-arrow"></span></a></li></ul></li><li id="menu-item-343691" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children w-nav-item level_1 menu-item-343691"><a class="w-nav-anchor level_1" href="https://training.brentozar.com"><span class="w-nav-title">Training</span><span class="w-nav-arrow"></span></a><ul class="w-nav-list level_2"><li id="menu-item-336079" class="menu-item menu-item-type-post_type menu-item-object-page w-nav-item level_2 menu-item-336079"><a class="w-nav-anchor level_2" href="https://www.brentozar.com/training/live/"><span class="w-nav-title">Watch Brent Streaming Live</span><span class="w-nav-arrow"></span></a></li><li id="menu-item-137838" class="menu-item menu-item-type-custom menu-item-object-custom w-nav-item level_2 menu-item-137838"><a class="w-nav-anchor level_2" href="https://www.brentozar.com/training/my-videos/"><span class="w-nav-title">My Videos and Downloads</span><span class="w-nav-arrow"></span></a></li><li id="menu-item-137837" class="menu-item menu-item-type-custom menu-item-object-custom w-nav-item level_2 menu-item-137837"><a class="w-nav-anchor level_2" href="https://www.brentozar.com/my-account/"><span class="w-nav-title">My Account</span><span class="w-nav-arrow"></span></a></li><li id="menu-item-332996" class="menu-item menu-item-type-post_type menu-item-object-page w-nav-item level_2 menu-item-332996"><a class="w-nav-anchor level_2" href="https://www.brentozar.com/corporate-training/"><span class="w-nav-title">Private SQL Server Training</span><span class="w-nav-arrow"></span></a></li><li id="menu-item-59041" class="menu-item menu-item-type-post_type menu-item-object-page w-nav-item level_2 menu-item-59041"><a class="w-nav-anchor level_2" href="https://www.brentozar.com/training/training-faq/"><span class="w-nav-title">Training FAQ</span><span class="w-nav-arrow"></span></a></li></ul></li><li id="menu-item-112833" class="menu-item menu-item-type-post_type menu-item-object-page w-nav-item level_1 menu-item-112833"><a class="w-nav-anchor level_1" href="https://www.brentozar.com/sql-constantcare/"><span class="w-nav-title">Monitoring</span><span class="w-nav-arrow"></span></a></li><li id="menu-item-25024" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children w-nav-item level_1 menu-item-25024"><a class="w-nav-anchor level_1" href="https://www.brentozar.com/first-aid/"><span class="w-nav-title">Scripts</span><span class="w-nav-arrow"></span></a><ul class="w-nav-list level_2"><li id="menu-item-25147" class="menu-item menu-item-type-custom menu-item-object-custom w-nav-item level_2 menu-item-25147"><a class="w-nav-anchor level_2" href="https://www.brentozar.com/blitz/"><span class="w-nav-title">sp_Blitz &#8211; free health check</span><span class="w-nav-arrow"></span></a></li><li id="menu-item-25145" class="menu-item menu-item-type-post_type menu-item-object-page w-nav-item level_2 menu-item-25145"><a class="w-nav-anchor level_2" href="https://www.brentozar.com/blitzcache/"><span class="w-nav-title">sp_BlitzCache &#8211; find queries to tune</span><span class="w-nav-arrow"></span></a></li><li id="menu-item-25144" class="menu-item menu-item-type-post_type menu-item-object-page w-nav-item level_2 menu-item-25144"><a class="w-nav-anchor level_2" href="https://www.brentozar.com/askbrent/"><span class="w-nav-title">sp_BlitzFirst &#8211; instant performance check</span><span class="w-nav-arrow"></span></a></li><li id="menu-item-25148" class="menu-item menu-item-type-custom menu-item-object-custom w-nav-item level_2 menu-item-25148"><a class="w-nav-anchor level_2" href="https://www.brentozar.com/blitzindex/"><span class="w-nav-title">sp_BlitzIndex &#8211; design the right indexes</span><span class="w-nav-arrow"></span></a></li><li id="menu-item-97404" class="menu-item menu-item-type-custom menu-item-object-custom w-nav-item level_2 menu-item-97404"><a class="w-nav-anchor level_2" href="https://www.brentozar.com/first-aid/sp_blitzwho/"><span class="w-nav-title">sp_BlitzWho &#8211; what&#8217;s happening right now</span><span class="w-nav-arrow"></span></a></li><li id="menu-item-25122" class="menu-item menu-item-type-custom menu-item-object-custom w-nav-item level_2 menu-item-25122"><a class="w-nav-anchor level_2" href="https://www.brentozar.com/pastetheplan/"><span class="w-nav-title">PasteThePlan &#8211; share query plans</span><span class="w-nav-arrow"></span></a></li></ul></li><li id="menu-item-25025" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children w-nav-item level_1 menu-item-25025"><a class="w-nav-anchor level_1" href="https://www.brentozar.com/blog/"><span class="w-nav-title">Blog</span><span class="w-nav-arrow"></span></a><ul class="w-nav-list level_2"><li id="menu-item-26175" class="menu-item menu-item-type-taxonomy menu-item-object-category w-nav-item level_2 menu-item-26175"><a class="w-nav-anchor level_2" href="https://www.brentozar.com/archive/category/development/t-sql/"><span class="w-nav-title">T-SQL</span><span class="w-nav-arrow"></span></a></li><li id="menu-item-26137" class="menu-item menu-item-type-taxonomy menu-item-object-category w-nav-item level_2 menu-item-26137"><a class="w-nav-anchor level_2" href="https://www.brentozar.com/archive/category/development/execution-plans/"><span class="w-nav-title">Execution Plans</span><span class="w-nav-arrow"></span></a></li><li id="menu-item-26139" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor w-nav-item level_2 menu-item-26139"><a class="w-nav-anchor level_2" href="https://www.brentozar.com/archive/category/indexing/"><span class="w-nav-title">Indexing</span><span class="w-nav-arrow"></span></a></li><li id="menu-item-277344" class="menu-item menu-item-type-taxonomy menu-item-object-category w-nav-item level_2 menu-item-277344"><a class="w-nav-anchor level_2" href="https://www.brentozar.com/archive/category/videos/"><span class="w-nav-title">Videos</span><span class="w-nav-arrow"></span></a></li><li id="menu-item-26126" class="menu-item menu-item-type-taxonomy menu-item-object-category w-nav-item level_2 menu-item-26126"><a class="w-nav-anchor level_2" href="https://www.brentozar.com/archive/category/architecture/"><span class="w-nav-title">Architecture</span><span class="w-nav-arrow"></span></a></li><li id="menu-item-26127" class="menu-item menu-item-type-taxonomy menu-item-object-category w-nav-item level_2 menu-item-26127"><a class="w-nav-anchor level_2" href="https://www.brentozar.com/archive/category/backup-and-recovery/"><span class="w-nav-title">Backup and Recovery</span><span class="w-nav-arrow"></span></a></li><li id="menu-item-26132" class="menu-item menu-item-type-taxonomy menu-item-object-category w-nav-item level_2 menu-item-26132"><a class="w-nav-anchor level_2" href="https://www.brentozar.com/archive/category/cloud-computers/"><span class="w-nav-title">Cloud Computing</span><span class="w-nav-arrow"></span></a></li><li id="menu-item-26136" class="menu-item menu-item-type-taxonomy menu-item-object-category w-nav-item level_2 menu-item-26136"><a class="w-nav-anchor level_2" href="https://www.brentozar.com/archive/category/development/"><span class="w-nav-title">Development</span><span class="w-nav-arrow"></span></a></li><li id="menu-item-26145" class="menu-item menu-item-type-taxonomy menu-item-object-category w-nav-item level_2 menu-item-26145"><a class="w-nav-anchor level_2" href="https://www.brentozar.com/archive/category/first-responder-kit/"><span class="w-nav-title">First Responder Kit</span><span class="w-nav-arrow"></span></a></li><li id="menu-item-26147" class="menu-item menu-item-type-taxonomy menu-item-object-category w-nav-item level_2 menu-item-26147"><a class="w-nav-anchor level_2" href="https://www.brentozar.com/archive/category/high-availability/"><span class="w-nav-title">High Availability</span><span class="w-nav-arrow"></span></a></li><li id="menu-item-26152" class="menu-item menu-item-type-taxonomy menu-item-object-category w-nav-item level_2 menu-item-26152"><a class="w-nav-anchor level_2" href="https://www.brentozar.com/archive/category/humor/"><span class="w-nav-title">Humor</span><span class="w-nav-arrow"></span></a></li><li id="menu-item-26143" class="menu-item menu-item-type-taxonomy menu-item-object-category w-nav-item level_2 menu-item-26143"><a class="w-nav-anchor level_2" href="https://www.brentozar.com/archive/category/development/locking-blocking-and-isolation-levels/"><span class="w-nav-title">Locking, Blocking, and Isolation Levels</span><span class="w-nav-arrow"></span></a></li><li id="menu-item-331654" class="menu-item menu-item-type-taxonomy menu-item-object-category w-nav-item level_2 menu-item-331654"><a class="w-nav-anchor level_2" href="https://www.brentozar.com/archive/category/development/parameter-sniffing/"><span class="w-nav-title">Parameter Sniffing</span><span class="w-nav-arrow"></span></a></li><li id="menu-item-26158" class="menu-item menu-item-type-taxonomy menu-item-object-category w-nav-item level_2 menu-item-26158"><a class="w-nav-anchor level_2" href="https://www.brentozar.com/archive/category/production-database-administration/"><span class="w-nav-title">Production Database Administration</span><span class="w-nav-arrow"></span></a></li><li id="menu-item-26162" class="menu-item menu-item-type-taxonomy menu-item-object-category w-nav-item level_2 menu-item-26162"><a class="w-nav-anchor level_2" href="https://www.brentozar.com/archive/category/professional-development/"><span class="w-nav-title">Professional Development</span><span class="w-nav-arrow"></span></a></li><li id="menu-item-117311" class="menu-item menu-item-type-taxonomy menu-item-object-category w-nav-item level_2 menu-item-117311"><a class="w-nav-anchor level_2" href="https://www.brentozar.com/archive/category/sql-constantcare/"><span class="w-nav-title">SQL ConstantCare</span><span class="w-nav-arrow"></span></a></li></ul></li><li class="w-nav-close"></li></ul><div class="w-nav-options hidden" onclick='return {&quot;mobileWidth&quot;:900,&quot;mobileBehavior&quot;:0}'></div></nav></div><div class="l-subheader-cell at_right"></div></div></div><div class="l-subheader for_hidden hidden"></div></header><main id="page-content" class="l-main" itemprop="mainContentOfPage">
	<section class="l-section height_auto for_sidebar at_right"><div class="l-section-h"><div class="l-content"><div class="vc_column-inner"><section class="l-section wpb_row us_custom_e11ab399 for_blogpost height_medium"><div class="l-section-h i-cf"><div class="g-cols vc_row via_flex valign_top type_default stacking_default"><div class="vc_col-sm-12 wpb_column vc_column_container"><div class="vc_column-inner"><div class="wpb_wrapper"><h1 class="w-post-elm post_title us_custom_e2aee182 entry-title color_link_inherit">Columnstore Indexes are Finally Sorted in SQL Server 2022.</h1><div class="w-hwrapper highlight_faded align_none valign_top"><time class="w-post-elm post_date us_custom_ea2be81a entry-date updated" datetime="2022-07-12T06:33:37+00:00" title="12 July 2022 at 06:33:37 UTC" itemprop="dateModified"><i class="far fa-clock"></i><span class="w-post-elm-before">Last Updated </span>1 week ago</time><div class="w-post-elm post_author us_custom_ea2be81a vcard author color_link_inherit"><i class="far fa-user"></i><div class="post-author-meta"><a href="https://www.brentozar.com/archive/author/brento/" class="post-author-name fn">Brent Ozar</a></div></div><div class="w-post-elm post_taxonomy us_custom_ea2be81a style_simple color_link_inherit"><i class="far fa-folder-open"></i><a href="https://www.brentozar.com/archive/category/indexing/columnstore-indexes/">Columnstore Indexes</a></div><div class="w-post-elm post_comments us_custom_ea2be81a layout_amount color_link_inherit"><i class="far fa-comments"></i><a class="smooth-scroll" href="https://www.brentozar.com/archive/2022/07/columnstore-indexes-are-finally-sorted-in-sql-server-2022/#comments">20 <span class="screen-reader-text">Comments</span></a></div></div></div></div></div></div></div></section><section class="l-section wpb_row height_small"><div class="l-section-h i-cf"><div class="g-cols vc_row via_flex valign_top type_default stacking_default"><div class="vc_col-sm-12 wpb_column vc_column_container"><div class="vc_column-inner"><div class="wpb_wrapper"><div class="w-post-elm post_content" itemprop="text"><p>There&#8217;s a widespread misconception that SQL Server&#8217;s columnstore indexes are like an index on every column.</p>
<p>I debunk that myth in the first 30 minutes of <a href="https://training.brentozar.com/p/fundamentals-of-columnstore-indexes">my Fundamentals of Columnstore class</a>, where I explain that a better way to think of them is that your table is broken up into groups of rows (1M rows or less per group), and in each group, there&#8217;s an index on every column.</p>
<p>So essentially, every column has a whole bunch of indexes on it.</p>
<p><em>But there&#8217;s no order whatsoever as to which rows end up in which index.</em></p>
<p>This isn&#8217;t a problem for relatively small tables, but as you get to billion-row data warehouse fact tables where columnstore should really shine, performance gradually degrades. In data warehouses, fact tables often have a commonly filtered column, like SaleDate. However, until SQL Server 2022, even if you wanted a small SaleDate range, your query would likely check hundreds or thousands of row groups, each of which had a huge range of data.</p>
<h3>Here&#8217;s the problem before SQL Server 2022.</h3>
<p>Take the Users table from <a href="https://www.brentozar.com/archive/2015/10/how-to-download-the-stack-overflow-database-via-bittorrent/">the Stack Overflow database</a> &#8211; it&#8217;s a bad candidate for clustered columnstore for reasons that we discuss in the class, but it&#8217;s the table most of y&#8217;all are familiar with, so we&#8217;ll start there. We&#8217;ll create a new table and put a clustered columnstore index on it:</p><!-- Urvanov Syntax Highlighter v2.8.27 -->

		<div id="urvanov-syntax-highlighter-62d9f14d16c51703532139" class="urvanov-syntax-highlighter-syntax crayon-theme-classic urvanov-syntax-highlighter-font-monaco urvanov-syntax-highlighter-os-pc print-yes notranslate" data-settings=" minimize scroll-mouseover" style=" margin-top: 12px; margin-bottom: 12px; font-size: 12px !important; line-height: 15px !important;">
		
			<div class="crayon-toolbar" data-settings=" mouseover overlay hide delay" style="font-size: 12px !important;height: 18px !important; line-height: 18px !important;"><span class="crayon-title"></span>
			<div class="crayon-tools" style="font-size: 12px !important;height: 18px !important; line-height: 18px !important;"><div class="crayon-button urvanov-syntax-highlighter-nums-button" title="Toggle Line Numbers"><div class="urvanov-syntax-highlighter-button-icon"></div></div><div class="crayon-button urvanov-syntax-highlighter-plain-button" title="Toggle Plain Code"><div class="urvanov-syntax-highlighter-button-icon"></div></div><div class="crayon-button urvanov-syntax-highlighter-wrap-button" title="Toggle Line Wrap"><div class="urvanov-syntax-highlighter-button-icon"></div></div><div class="crayon-button urvanov-syntax-highlighter-expand-button" title="Expand Code"><div class="urvanov-syntax-highlighter-button-icon"></div></div><div class="crayon-button urvanov-syntax-highlighter-copy-button" title="Copy"><div class="urvanov-syntax-highlighter-button-icon"></div></div><div class="crayon-button urvanov-syntax-highlighter-popup-button" title="Open Code In New Window"><div class="urvanov-syntax-highlighter-button-icon"></div></div></div></div>
			<div class="crayon-info" style="min-height: 16.8px !important; line-height: 16.8px !important;"></div>
			<div class="urvanov-syntax-highlighter-plain-wrap"><textarea wrap="soft" class="urvanov-syntax-highlighter-plain print-no" data-settings="dblclick" readonly style="-moz-tab-size:4; -o-tab-size:4; -webkit-tab-size:4; tab-size:4; font-size: 12px !important; line-height: 15px !important;">
DROP TABLE IF EXISTS [dbo].[Users_columnstore];
GO
CREATE TABLE [dbo].[Users_columnstore](
	[Id] [int] IDENTITY(1,1),
	[AboutMe] [nvarchar](4000) NULL,
	[Age] [int] NULL,
	[CreationDate] [datetime] NOT NULL,
	[DisplayName] [nvarchar](40) NOT NULL,
	[DownVotes] [int] NOT NULL,
	[EmailHash] [nvarchar](40) NULL,
	[LastAccessDate] [datetime] NOT NULL,
	[Location] [nvarchar](100) NULL,
	[Reputation] [int] NOT NULL,
	[UpVotes] [int] NOT NULL,
	[Views] [int] NOT NULL,
	[WebsiteUrl] [nvarchar](200) NULL,
	[AccountId] [int] NULL)
GO
CREATE CLUSTERED COLUMNSTORE INDEX CCI 
	ON dbo.Users_Columnstore;
GO
SET IDENTITY_INSERT dbo.Users_columnstore ON;
GO
INSERT INTO dbo.Users_columnstore([Id], [AboutMe], [Age], [CreationDate], [DisplayName], [DownVotes], 
		[EmailHash], [LastAccessDate], [Location], [Reputation], [UpVotes], [Views], [WebsiteUrl], [AccountId])
	SELECT [Id], LEFT([AboutMe], 4000), [Age], [CreationDate], [DisplayName], [DownVotes], 
		[EmailHash], [LastAccessDate], [Location], [Reputation], [UpVotes], [Views], [WebsiteUrl], [AccountId]
	FROM dbo.Users;
GO
SET IDENTITY_INSERT dbo.Users_columnstore OFF;
GO</textarea></div>
			<div class="urvanov-syntax-highlighter-main" style="">
				<table class="crayon-table">
					<tr class="urvanov-syntax-highlighter-row">
				<td class="crayon-nums " data-settings="show">
					<div class="urvanov-syntax-highlighter-nums-content" style="font-size: 12px !important; line-height: 15px !important;"><div class="crayon-num" data-line="urvanov-syntax-highlighter-62d9f14d16c51703532139-1">1</div><div class="crayon-num crayon-striped-num" data-line="urvanov-syntax-highlighter-62d9f14d16c51703532139-2">2</div><div class="crayon-num" data-line="urvanov-syntax-highlighter-62d9f14d16c51703532139-3">3</div><div class="crayon-num crayon-striped-num" data-line="urvanov-syntax-highlighter-62d9f14d16c51703532139-4">4</div><div class="crayon-num" data-line="urvanov-syntax-highlighter-62d9f14d16c51703532139-5">5</div><div class="crayon-num crayon-striped-num" data-line="urvanov-syntax-highlighter-62d9f14d16c51703532139-6">6</div><div class="crayon-num" data-line="urvanov-syntax-highlighter-62d9f14d16c51703532139-7">7</div><div class="crayon-num crayon-striped-num" data-line="urvanov-syntax-highlighter-62d9f14d16c51703532139-8">8</div><div class="crayon-num" data-line="urvanov-syntax-highlighter-62d9f14d16c51703532139-9">9</div><div class="crayon-num crayon-striped-num" data-line="urvanov-syntax-highlighter-62d9f14d16c51703532139-10">10</div><div class="crayon-num" data-line="urvanov-syntax-highlighter-62d9f14d16c51703532139-11">11</div><div class="crayon-num crayon-striped-num" data-line="urvanov-syntax-highlighter-62d9f14d16c51703532139-12">12</div><div class="crayon-num" data-line="urvanov-syntax-highlighter-62d9f14d16c51703532139-13">13</div><div class="crayon-num crayon-striped-num" data-line="urvanov-syntax-highlighter-62d9f14d16c51703532139-14">14</div><div class="crayon-num" data-line="urvanov-syntax-highlighter-62d9f14d16c51703532139-15">15</div><div class="crayon-num crayon-striped-num" data-line="urvanov-syntax-highlighter-62d9f14d16c51703532139-16">16</div><div class="crayon-num" data-line="urvanov-syntax-highlighter-62d9f14d16c51703532139-17">17</div><div class="crayon-num crayon-striped-num" data-line="urvanov-syntax-highlighter-62d9f14d16c51703532139-18">18</div><div class="crayon-num" data-line="urvanov-syntax-highlighter-62d9f14d16c51703532139-19">19</div><div class="crayon-num crayon-striped-num" data-line="urvanov-syntax-highlighter-62d9f14d16c51703532139-20">20</div><div class="crayon-num" data-line="urvanov-syntax-highlighter-62d9f14d16c51703532139-21">21</div><div class="crayon-num crayon-striped-num" data-line="urvanov-syntax-highlighter-62d9f14d16c51703532139-22">22</div><div class="crayon-num" data-line="urvanov-syntax-highlighter-62d9f14d16c51703532139-23">23</div><div class="crayon-num crayon-striped-num" data-line="urvanov-syntax-highlighter-62d9f14d16c51703532139-24">24</div><div class="crayon-num" data-line="urvanov-syntax-highlighter-62d9f14d16c51703532139-25">25</div><div class="crayon-num crayon-striped-num" data-line="urvanov-syntax-highlighter-62d9f14d16c51703532139-26">26</div><div class="crayon-num" data-line="urvanov-syntax-highlighter-62d9f14d16c51703532139-27">27</div><div class="crayon-num crayon-striped-num" data-line="urvanov-syntax-highlighter-62d9f14d16c51703532139-28">28</div><div class="crayon-num" data-line="urvanov-syntax-highlighter-62d9f14d16c51703532139-29">29</div><div class="crayon-num crayon-striped-num" data-line="urvanov-syntax-highlighter-62d9f14d16c51703532139-30">30</div><div class="crayon-num" data-line="urvanov-syntax-highlighter-62d9f14d16c51703532139-31">31</div></div>
				</td>
						<td class="urvanov-syntax-highlighter-code"><div class="crayon-pre" style="font-size: 12px !important; line-height: 15px !important; -moz-tab-size:4; -o-tab-size:4; -webkit-tab-size:4; tab-size:4;"><div class="crayon-line" id="urvanov-syntax-highlighter-62d9f14d16c51703532139-1"><span class="crayon-e">DROP </span><span class="crayon-e">TABLE </span><span class="crayon-st">IF</span><span class="crayon-h"> </span><span class="crayon-i">EXISTS</span><span class="crayon-h"> </span><span class="crayon-sy">[</span><span class="crayon-v">dbo</span><span class="crayon-sy">]</span><span class="crayon-sy">.</span><span class="crayon-sy">[</span><span class="crayon-v">Users_columnstore</span><span class="crayon-sy">]</span><span class="crayon-sy">;</span></div><div class="crayon-line crayon-striped-line" id="urvanov-syntax-highlighter-62d9f14d16c51703532139-2"><span class="crayon-e">GO</span></div><div class="crayon-line" id="urvanov-syntax-highlighter-62d9f14d16c51703532139-3"><span class="crayon-e">CREATE </span><span class="crayon-i">TABLE</span><span class="crayon-h"> </span><span class="crayon-sy">[</span><span class="crayon-v">dbo</span><span class="crayon-sy">]</span><span class="crayon-sy">.</span><span class="crayon-sy">[</span><span class="crayon-v">Users_columnstore</span><span class="crayon-sy">]</span><span class="crayon-sy">(</span></div><div class="crayon-line crayon-striped-line" id="urvanov-syntax-highlighter-62d9f14d16c51703532139-4"><span class="crayon-h">	</span><span class="crayon-sy">[</span><span class="crayon-v">Id</span><span class="crayon-sy">]</span><span class="crayon-h"> </span><span class="crayon-sy">[</span><span class="crayon-t">int</span><span class="crayon-sy">]</span><span class="crayon-h"> </span><span class="crayon-e">IDENTITY</span><span class="crayon-sy">(</span><span class="crayon-cn">1</span><span class="crayon-sy">,</span><span class="crayon-cn">1</span><span class="crayon-sy">)</span><span class="crayon-sy">,</span></div><div class="crayon-line" id="urvanov-syntax-highlighter-62d9f14d16c51703532139-5"><span class="crayon-h">	</span><span class="crayon-sy">[</span><span class="crayon-v">AboutMe</span><span class="crayon-sy">]</span><span class="crayon-h"> </span><span class="crayon-sy">[</span><span class="crayon-v">nvarchar</span><span class="crayon-sy">]</span><span class="crayon-sy">(</span><span class="crayon-cn">4000</span><span class="crayon-sy">)</span><span class="crayon-h"> </span><span class="crayon-t">NULL</span><span class="crayon-sy">,</span></div><div class="crayon-line crayon-striped-line" id="urvanov-syntax-highlighter-62d9f14d16c51703532139-6"><span class="crayon-h">	</span><span class="crayon-sy">[</span><span class="crayon-v">Age</span><span class="crayon-sy">]</span><span class="crayon-h"> </span><span class="crayon-sy">[</span><span class="crayon-t">int</span><span class="crayon-sy">]</span><span class="crayon-h"> </span><span class="crayon-t">NULL</span><span class="crayon-sy">,</span></div><div class="crayon-line" id="urvanov-syntax-highlighter-62d9f14d16c51703532139-7"><span class="crayon-h">	</span><span class="crayon-sy">[</span><span class="crayon-v">CreationDate</span><span class="crayon-sy">]</span><span class="crayon-h"> </span><span class="crayon-sy">[</span><span class="crayon-v">datetime</span><span class="crayon-sy">]</span><span class="crayon-h"> </span><span class="crayon-st">NOT</span><span class="crayon-h"> </span><span class="crayon-t">NULL</span><span class="crayon-sy">,</span></div><div class="crayon-line crayon-striped-line" id="urvanov-syntax-highlighter-62d9f14d16c51703532139-8"><span class="crayon-h">	</span><span class="crayon-sy">[</span><span class="crayon-v">DisplayName</span><span class="crayon-sy">]</span><span class="crayon-h"> </span><span class="crayon-sy">[</span><span class="crayon-v">nvarchar</span><span class="crayon-sy">]</span><span class="crayon-sy">(</span><span class="crayon-cn">40</span><span class="crayon-sy">)</span><span class="crayon-h"> </span><span class="crayon-st">NOT</span><span class="crayon-h"> </span><span class="crayon-t">NULL</span><span class="crayon-sy">,</span></div><div class="crayon-line" id="urvanov-syntax-highlighter-62d9f14d16c51703532139-9"><span class="crayon-h">	</span><span class="crayon-sy">[</span><span class="crayon-v">DownVotes</span><span class="crayon-sy">]</span><span class="crayon-h"> </span><span class="crayon-sy">[</span><span class="crayon-t">int</span><span class="crayon-sy">]</span><span class="crayon-h"> </span><span class="crayon-st">NOT</span><span class="crayon-h"> </span><span class="crayon-t">NULL</span><span class="crayon-sy">,</span></div><div class="crayon-line crayon-striped-line" id="urvanov-syntax-highlighter-62d9f14d16c51703532139-10"><span class="crayon-h">	</span><span class="crayon-sy">[</span><span class="crayon-v">EmailHash</span><span class="crayon-sy">]</span><span class="crayon-h"> </span><span class="crayon-sy">[</span><span class="crayon-v">nvarchar</span><span class="crayon-sy">]</span><span class="crayon-sy">(</span><span class="crayon-cn">40</span><span class="crayon-sy">)</span><span class="crayon-h"> </span><span class="crayon-t">NULL</span><span class="crayon-sy">,</span></div><div class="crayon-line" id="urvanov-syntax-highlighter-62d9f14d16c51703532139-11"><span class="crayon-h">	</span><span class="crayon-sy">[</span><span class="crayon-v">LastAccessDate</span><span class="crayon-sy">]</span><span class="crayon-h"> </span><span class="crayon-sy">[</span><span class="crayon-v">datetime</span><span class="crayon-sy">]</span><span class="crayon-h"> </span><span class="crayon-st">NOT</span><span class="crayon-h"> </span><span class="crayon-t">NULL</span><span class="crayon-sy">,</span></div><div class="crayon-line crayon-striped-line" id="urvanov-syntax-highlighter-62d9f14d16c51703532139-12"><span class="crayon-h">	</span><span class="crayon-sy">[</span><span class="crayon-v">Location</span><span class="crayon-sy">]</span><span class="crayon-h"> </span><span class="crayon-sy">[</span><span class="crayon-v">nvarchar</span><span class="crayon-sy">]</span><span class="crayon-sy">(</span><span class="crayon-cn">100</span><span class="crayon-sy">)</span><span class="crayon-h"> </span><span class="crayon-t">NULL</span><span class="crayon-sy">,</span></div><div class="crayon-line" id="urvanov-syntax-highlighter-62d9f14d16c51703532139-13"><span class="crayon-h">	</span><span class="crayon-sy">[</span><span class="crayon-v">Reputation</span><span class="crayon-sy">]</span><span class="crayon-h"> </span><span class="crayon-sy">[</span><span class="crayon-t">int</span><span class="crayon-sy">]</span><span class="crayon-h"> </span><span class="crayon-st">NOT</span><span class="crayon-h"> </span><span class="crayon-t">NULL</span><span class="crayon-sy">,</span></div><div class="crayon-line crayon-striped-line" id="urvanov-syntax-highlighter-62d9f14d16c51703532139-14"><span class="crayon-h">	</span><span class="crayon-sy">[</span><span class="crayon-v">UpVotes</span><span class="crayon-sy">]</span><span class="crayon-h"> </span><span class="crayon-sy">[</span><span class="crayon-t">int</span><span class="crayon-sy">]</span><span class="crayon-h"> </span><span class="crayon-st">NOT</span><span class="crayon-h"> </span><span class="crayon-t">NULL</span><span class="crayon-sy">,</span></div><div class="crayon-line" id="urvanov-syntax-highlighter-62d9f14d16c51703532139-15"><span class="crayon-h">	</span><span class="crayon-sy">[</span><span class="crayon-v">Views</span><span class="crayon-sy">]</span><span class="crayon-h"> </span><span class="crayon-sy">[</span><span class="crayon-t">int</span><span class="crayon-sy">]</span><span class="crayon-h"> </span><span class="crayon-st">NOT</span><span class="crayon-h"> </span><span class="crayon-t">NULL</span><span class="crayon-sy">,</span></div><div class="crayon-line crayon-striped-line" id="urvanov-syntax-highlighter-62d9f14d16c51703532139-16"><span class="crayon-h">	</span><span class="crayon-sy">[</span><span class="crayon-v">WebsiteUrl</span><span class="crayon-sy">]</span><span class="crayon-h"> </span><span class="crayon-sy">[</span><span class="crayon-v">nvarchar</span><span class="crayon-sy">]</span><span class="crayon-sy">(</span><span class="crayon-cn">200</span><span class="crayon-sy">)</span><span class="crayon-h"> </span><span class="crayon-t">NULL</span><span class="crayon-sy">,</span></div><div class="crayon-line" id="urvanov-syntax-highlighter-62d9f14d16c51703532139-17"><span class="crayon-h">	</span><span class="crayon-sy">[</span><span class="crayon-v">AccountId</span><span class="crayon-sy">]</span><span class="crayon-h"> </span><span class="crayon-sy">[</span><span class="crayon-t">int</span><span class="crayon-sy">]</span><span class="crayon-h"> </span><span class="crayon-t">NULL</span><span class="crayon-sy">)</span></div><div class="crayon-line crayon-striped-line" id="urvanov-syntax-highlighter-62d9f14d16c51703532139-18"><span class="crayon-e">GO</span></div><div class="crayon-line" id="urvanov-syntax-highlighter-62d9f14d16c51703532139-19"><span class="crayon-e">CREATE </span><span class="crayon-e">CLUSTERED </span><span class="crayon-e">COLUMNSTORE </span><span class="crayon-e">INDEX </span><span class="crayon-e">CCI </span></div><div class="crayon-line crayon-striped-line" id="urvanov-syntax-highlighter-62d9f14d16c51703532139-20"><span class="crayon-e">	</span><span class="crayon-e">ON </span><span class="crayon-v">dbo</span><span class="crayon-sy">.</span><span class="crayon-v">Users_Columnstore</span><span class="crayon-sy">;</span></div><div class="crayon-line" id="urvanov-syntax-highlighter-62d9f14d16c51703532139-21"><span class="crayon-e">GO</span></div><div class="crayon-line crayon-striped-line" id="urvanov-syntax-highlighter-62d9f14d16c51703532139-22"><span class="crayon-e">SET </span><span class="crayon-e">IDENTITY_INSERT </span><span class="crayon-v">dbo</span><span class="crayon-sy">.</span><span class="crayon-e">Users_columnstore </span><span class="crayon-v">ON</span><span class="crayon-sy">;</span></div><div class="crayon-line" id="urvanov-syntax-highlighter-62d9f14d16c51703532139-23"><span class="crayon-e">GO</span></div><div class="crayon-line crayon-striped-line" id="urvanov-syntax-highlighter-62d9f14d16c51703532139-24"><span class="crayon-e">INSERT </span><span class="crayon-e">INTO </span><span class="crayon-v">dbo</span><span class="crayon-sy">.</span><span class="crayon-e">Users_columnstore</span><span class="crayon-sy">(</span><span class="crayon-sy">[</span><span class="crayon-v">Id</span><span class="crayon-sy">]</span><span class="crayon-sy">,</span><span class="crayon-h"> </span><span class="crayon-sy">[</span><span class="crayon-v">AboutMe</span><span class="crayon-sy">]</span><span class="crayon-sy">,</span><span class="crayon-h"> </span><span class="crayon-sy">[</span><span class="crayon-v">Age</span><span class="crayon-sy">]</span><span class="crayon-sy">,</span><span class="crayon-h"> </span><span class="crayon-sy">[</span><span class="crayon-v">CreationDate</span><span class="crayon-sy">]</span><span class="crayon-sy">,</span><span class="crayon-h"> </span><span class="crayon-sy">[</span><span class="crayon-v">DisplayName</span><span class="crayon-sy">]</span><span class="crayon-sy">,</span><span class="crayon-h"> </span><span class="crayon-sy">[</span><span class="crayon-v">DownVotes</span><span class="crayon-sy">]</span><span class="crayon-sy">,</span><span class="crayon-h"> </span></div><div class="crayon-line" id="urvanov-syntax-highlighter-62d9f14d16c51703532139-25"><span class="crayon-h">		</span><span class="crayon-sy">[</span><span class="crayon-v">EmailHash</span><span class="crayon-sy">]</span><span class="crayon-sy">,</span><span class="crayon-h"> </span><span class="crayon-sy">[</span><span class="crayon-v">LastAccessDate</span><span class="crayon-sy">]</span><span class="crayon-sy">,</span><span class="crayon-h"> </span><span class="crayon-sy">[</span><span class="crayon-v">Location</span><span class="crayon-sy">]</span><span class="crayon-sy">,</span><span class="crayon-h"> </span><span class="crayon-sy">[</span><span class="crayon-v">Reputation</span><span class="crayon-sy">]</span><span class="crayon-sy">,</span><span class="crayon-h"> </span><span class="crayon-sy">[</span><span class="crayon-v">UpVotes</span><span class="crayon-sy">]</span><span class="crayon-sy">,</span><span class="crayon-h"> </span><span class="crayon-sy">[</span><span class="crayon-v">Views</span><span class="crayon-sy">]</span><span class="crayon-sy">,</span><span class="crayon-h"> </span><span class="crayon-sy">[</span><span class="crayon-v">WebsiteUrl</span><span class="crayon-sy">]</span><span class="crayon-sy">,</span><span class="crayon-h"> </span><span class="crayon-sy">[</span><span class="crayon-v">AccountId</span><span class="crayon-sy">]</span><span class="crayon-sy">)</span></div><div class="crayon-line crayon-striped-line" id="urvanov-syntax-highlighter-62d9f14d16c51703532139-26"><span class="crayon-h">	</span><span class="crayon-i">SELECT</span><span class="crayon-h"> </span><span class="crayon-sy">[</span><span class="crayon-v">Id</span><span class="crayon-sy">]</span><span class="crayon-sy">,</span><span class="crayon-h"> </span><span class="crayon-e">LEFT</span><span class="crayon-sy">(</span><span class="crayon-sy">[</span><span class="crayon-v">AboutMe</span><span class="crayon-sy">]</span><span class="crayon-sy">,</span><span class="crayon-h"> </span><span class="crayon-cn">4000</span><span class="crayon-sy">)</span><span class="crayon-sy">,</span><span class="crayon-h"> </span><span class="crayon-sy">[</span><span class="crayon-v">Age</span><span class="crayon-sy">]</span><span class="crayon-sy">,</span><span class="crayon-h"> </span><span class="crayon-sy">[</span><span class="crayon-v">CreationDate</span><span class="crayon-sy">]</span><span class="crayon-sy">,</span><span class="crayon-h"> </span><span class="crayon-sy">[</span><span class="crayon-v">DisplayName</span><span class="crayon-sy">]</span><span class="crayon-sy">,</span><span class="crayon-h"> </span><span class="crayon-sy">[</span><span class="crayon-v">DownVotes</span><span class="crayon-sy">]</span><span class="crayon-sy">,</span><span class="crayon-h"> </span></div><div class="crayon-line" id="urvanov-syntax-highlighter-62d9f14d16c51703532139-27"><span class="crayon-h">		</span><span class="crayon-sy">[</span><span class="crayon-v">EmailHash</span><span class="crayon-sy">]</span><span class="crayon-sy">,</span><span class="crayon-h"> </span><span class="crayon-sy">[</span><span class="crayon-v">LastAccessDate</span><span class="crayon-sy">]</span><span class="crayon-sy">,</span><span class="crayon-h"> </span><span class="crayon-sy">[</span><span class="crayon-v">Location</span><span class="crayon-sy">]</span><span class="crayon-sy">,</span><span class="crayon-h"> </span><span class="crayon-sy">[</span><span class="crayon-v">Reputation</span><span class="crayon-sy">]</span><span class="crayon-sy">,</span><span class="crayon-h"> </span><span class="crayon-sy">[</span><span class="crayon-v">UpVotes</span><span class="crayon-sy">]</span><span class="crayon-sy">,</span><span class="crayon-h"> </span><span class="crayon-sy">[</span><span class="crayon-v">Views</span><span class="crayon-sy">]</span><span class="crayon-sy">,</span><span class="crayon-h"> </span><span class="crayon-sy">[</span><span class="crayon-v">WebsiteUrl</span><span class="crayon-sy">]</span><span class="crayon-sy">,</span><span class="crayon-h"> </span><span class="crayon-sy">[</span><span class="crayon-v">AccountId</span><span class="crayon-sy">]</span></div><div class="crayon-line crayon-striped-line" id="urvanov-syntax-highlighter-62d9f14d16c51703532139-28"><span class="crayon-h">	</span><span class="crayon-e">FROM </span><span class="crayon-v">dbo</span><span class="crayon-sy">.</span><span class="crayon-v">Users</span><span class="crayon-sy">;</span></div><div class="crayon-line" id="urvanov-syntax-highlighter-62d9f14d16c51703532139-29"><span class="crayon-e">GO</span></div><div class="crayon-line crayon-striped-line" id="urvanov-syntax-highlighter-62d9f14d16c51703532139-30"><span class="crayon-e">SET </span><span class="crayon-e">IDENTITY_INSERT </span><span class="crayon-v">dbo</span><span class="crayon-sy">.</span><span class="crayon-e">Users_columnstore </span><span class="crayon-v">OFF</span><span class="crayon-sy">;</span></div><div class="crayon-line" id="urvanov-syntax-highlighter-62d9f14d16c51703532139-31"><span class="crayon-v">GO</span></div></div></td>
					</tr>
				</table>
			</div>
		</div>
<!-- [Format Time: 0.0016 seconds] -->
<p>
After loading the data, visualize the columnstore contents with sp_BlitzIndex, and at first, it looks like the table is broken up into randomly sized rowgroups, sorted by their Id:</p>
<p><a  href="https://www.brentozar.com/wp-content/uploads/2022/07/sorted_by_id.jpg"><img class="alignnone size-us_600_0 wp-image-348667" src="https://www.brentozar.com/wp-content/uploads/2022/07/sorted_by_id-600x217.jpg" alt="" width="600" height="217" srcset="https://www.brentozar.com/wp-content/uploads/2022/07/sorted_by_id-600x217.jpg 600w, https://www.brentozar.com/wp-content/uploads/2022/07/sorted_by_id-250x90.jpg 250w, https://www.brentozar.com/wp-content/uploads/2022/07/sorted_by_id.jpg 759w" sizes="(max-width: 600px) 100vw, 600px" /></a></p>
<p>But that&#8217;s simply because our source, the Users table, happened to be sorted by Id. Over time, as you delete/update/insert rows in this table, you&#8217;re going to need to do index maintenance on it. (I know I talk a lot of smack about people who do too much index maintenance on rowstore tables, but columnstore tables are very different &#8211; they actually <em>need</em> maintenance for the reasons we discuss in the class.)</p>
<p>After a couple of rounds of index rebuilds, check the contents again:</p><!-- Urvanov Syntax Highlighter v2.8.27 -->

		<div id="urvanov-syntax-highlighter-62d9f14d16c58820902619" class="urvanov-syntax-highlighter-syntax crayon-theme-classic urvanov-syntax-highlighter-font-monaco urvanov-syntax-highlighter-os-pc print-yes notranslate" data-settings=" minimize scroll-mouseover" style=" margin-top: 12px; margin-bottom: 12px; font-size: 12px !important; line-height: 15px !important;">
		
			<div class="crayon-toolbar" data-settings=" mouseover overlay hide delay" style="font-size: 12px !important;height: 18px !important; line-height: 18px !important;"><span class="crayon-title"></span>
			<div class="crayon-tools" style="font-size: 12px !important;height: 18px !important; line-height: 18px !important;"><div class="crayon-button urvanov-syntax-highlighter-nums-button" title="Toggle Line Numbers"><div class="urvanov-syntax-highlighter-button-icon"></div></div><div class="crayon-button urvanov-syntax-highlighter-plain-button" title="Toggle Plain Code"><div class="urvanov-syntax-highlighter-button-icon"></div></div><div class="crayon-button urvanov-syntax-highlighter-wrap-button" title="Toggle Line Wrap"><div class="urvanov-syntax-highlighter-button-icon"></div></div><div class="crayon-button urvanov-syntax-highlighter-expand-button" title="Expand Code"><div class="urvanov-syntax-highlighter-button-icon"></div></div><div class="crayon-button urvanov-syntax-highlighter-copy-button" title="Copy"><div class="urvanov-syntax-highlighter-button-icon"></div></div><div class="crayon-button urvanov-syntax-highlighter-popup-button" title="Open Code In New Window"><div class="urvanov-syntax-highlighter-button-icon"></div></div></div></div>
			<div class="crayon-info" style="min-height: 16.8px !important; line-height: 16.8px !important;"></div>
			<div class="urvanov-syntax-highlighter-plain-wrap"><textarea wrap="soft" class="urvanov-syntax-highlighter-plain print-no" data-settings="dblclick" readonly style="-moz-tab-size:4; -o-tab-size:4; -webkit-tab-size:4; tab-size:4; font-size: 12px !important; line-height: 15px !important;">
ALTER TABLE dbo.Users_columnstore REBUILD;
ALTER TABLE dbo.Users_columnstore REBUILD;
sp_BlitzIndex @TableName = 'Users_columnstore';</textarea></div>
			<div class="urvanov-syntax-highlighter-main" style="">
				<table class="crayon-table">
					<tr class="urvanov-syntax-highlighter-row">
				<td class="crayon-nums " data-settings="show">
					<div class="urvanov-syntax-highlighter-nums-content" style="font-size: 12px !important; line-height: 15px !important;"><div class="crayon-num" data-line="urvanov-syntax-highlighter-62d9f14d16c58820902619-1">1</div><div class="crayon-num crayon-striped-num" data-line="urvanov-syntax-highlighter-62d9f14d16c58820902619-2">2</div><div class="crayon-num" data-line="urvanov-syntax-highlighter-62d9f14d16c58820902619-3">3</div></div>
				</td>
						<td class="urvanov-syntax-highlighter-code"><div class="crayon-pre" style="font-size: 12px !important; line-height: 15px !important; -moz-tab-size:4; -o-tab-size:4; -webkit-tab-size:4; tab-size:4;"><div class="crayon-line" id="urvanov-syntax-highlighter-62d9f14d16c58820902619-1"><span class="crayon-e">ALTER </span><span class="crayon-e">TABLE </span><span class="crayon-v">dbo</span><span class="crayon-sy">.</span><span class="crayon-e">Users_columnstore </span><span class="crayon-v">REBUILD</span><span class="crayon-sy">;</span></div><div class="crayon-line crayon-striped-line" id="urvanov-syntax-highlighter-62d9f14d16c58820902619-2"><span class="crayon-e">ALTER </span><span class="crayon-e">TABLE </span><span class="crayon-v">dbo</span><span class="crayon-sy">.</span><span class="crayon-e">Users_columnstore </span><span class="crayon-v">REBUILD</span><span class="crayon-sy">;</span></div><div class="crayon-line" id="urvanov-syntax-highlighter-62d9f14d16c58820902619-3"><span class="crayon-v">sp</span><span class="crayon-sy">_</span>BlitzIndex<span class="crayon-h"> </span><span class="crayon-sy">@</span><span class="crayon-v">TableName</span><span class="crayon-h"> </span><span class="crayon-o">=</span><span class="crayon-h"> </span><span class="crayon-s">'Users_columnstore'</span><span class="crayon-sy">;</span></div></div></td>
					</tr>
				</table>
			</div>
		</div>
<!-- [Format Time: 0.0001 seconds] -->
<p>
And the rowgroups are literally sorted in random order:</p>
<p><a  href="https://www.brentozar.com/wp-content/uploads/2022/07/unordered_rowgroups.jpg"><img loading="lazy" class="alignnone size-us_600_0 wp-image-348668" src="https://www.brentozar.com/wp-content/uploads/2022/07/unordered_rowgroups-600x300.jpg" alt="" width="600" height="300" srcset="https://www.brentozar.com/wp-content/uploads/2022/07/unordered_rowgroups-600x300.jpg 600w, https://www.brentozar.com/wp-content/uploads/2022/07/unordered_rowgroups-250x125.jpg 250w, https://www.brentozar.com/wp-content/uploads/2022/07/unordered_rowgroups.jpg 754w" sizes="(max-width: 600px) 100vw, 600px" /></a></p>
<p>Meaning that if you want to find Id = 26837, you&#8217;re going to be checking multiple rowgroups &#8211; and more and more over time, as your data&#8217;s locations continue to randomize. This isn&#8217;t such a big problem for a tiny table like the 1GB Users table &#8211; but it&#8217;s a terrible problem for real-life sized tables, like the ones that really need columnstore.</p>
<h3>You could work around this &#8211;<br />
emphasis on work.</h3>
<p>You could reload the entire table regularly. It sounds extreme, but if the table isn&#8217;t large, and your hardware is fast enough to make a copy of the table sorted in the order where you want rowgroup elimination, it works. Copy the data into a new structure with a clustered index on that column, then create a clustered columnstore index again. The data will be ordered by the rowstore clustered index columns.</p>
<p>That solution doesn&#8217;t scale well for the kinds of shops that really need columnstore, though, because we&#8217;re talking about blowing the table back up to its full uncompressed size, and then compressing it all back down again &#8211; and all of this is a logged operation.</p>
<p>A better option is to partition the data by your commonly filtered column. I like this solution a lot at the billion-row tier because it also enables much better index maintenance strategies. I frequently point out that <a href="https://www.youtube.com/watch?v=iEa6_QnCFMU">daily rowstore index maintenance is usually a waste of resources</a>, even suggesting to scale back to monthly, but with columnstore indexes, things get a lot more complicated depending on your workload. We talk about that in class, too.</p>
<p>In theory, I&#8217;m a fan of partitioned views, too &#8211; using a table per year or per quarter &#8211; and then unioning them together. I just haven&#8217;t seen that solution implemented in the last several years though. I&#8217;m sure it&#8217;s out there &#8211; I just haven&#8217;t seen it lately.</p>
<h3>SQL Server 2022 fixes this<br />
with ordered columnstore indexes.</h3>
<p>Hey, go figure, indexes need to be put in order! Who knew? I mean, aside from all of us. Literally, every one of us. Here&#8217;s the <a href="https://docs.microsoft.com/en-us/sql/t-sql/statements/create-columnstore-index-transact-sql?view=sql-server-ver16">syntax from Books Online</a>:</p><!-- Urvanov Syntax Highlighter v2.8.27 -->

		<div id="urvanov-syntax-highlighter-62d9f14d16c59748952064" class="urvanov-syntax-highlighter-syntax crayon-theme-classic urvanov-syntax-highlighter-font-monaco urvanov-syntax-highlighter-os-pc print-yes notranslate" data-settings=" minimize scroll-mouseover" style=" margin-top: 12px; margin-bottom: 12px; font-size: 12px !important; line-height: 15px !important;">
		
			<div class="crayon-toolbar" data-settings=" mouseover overlay hide delay" style="font-size: 12px !important;height: 18px !important; line-height: 18px !important;"><span class="crayon-title"></span>
			<div class="crayon-tools" style="font-size: 12px !important;height: 18px !important; line-height: 18px !important;"><div class="crayon-button urvanov-syntax-highlighter-nums-button" title="Toggle Line Numbers"><div class="urvanov-syntax-highlighter-button-icon"></div></div><div class="crayon-button urvanov-syntax-highlighter-plain-button" title="Toggle Plain Code"><div class="urvanov-syntax-highlighter-button-icon"></div></div><div class="crayon-button urvanov-syntax-highlighter-wrap-button" title="Toggle Line Wrap"><div class="urvanov-syntax-highlighter-button-icon"></div></div><div class="crayon-button urvanov-syntax-highlighter-expand-button" title="Expand Code"><div class="urvanov-syntax-highlighter-button-icon"></div></div><div class="crayon-button urvanov-syntax-highlighter-copy-button" title="Copy"><div class="urvanov-syntax-highlighter-button-icon"></div></div><div class="crayon-button urvanov-syntax-highlighter-popup-button" title="Open Code In New Window"><div class="urvanov-syntax-highlighter-button-icon"></div></div></div></div>
			<div class="crayon-info" style="min-height: 16.8px !important; line-height: 16.8px !important;"></div>
			<div class="urvanov-syntax-highlighter-plain-wrap"><textarea wrap="soft" class="urvanov-syntax-highlighter-plain print-no" data-settings="dblclick" readonly style="-moz-tab-size:4; -o-tab-size:4; -webkit-tab-size:4; tab-size:4; font-size: 12px !important; line-height: 15px !important;">
CREATE CLUSTERED COLUMNSTORE INDEX CCI
ON dbo.Users_columnstore ORDER (Id)
WITH (DROP_EXISTING = ON);</textarea></div>
			<div class="urvanov-syntax-highlighter-main" style="">
				<table class="crayon-table">
					<tr class="urvanov-syntax-highlighter-row">
				<td class="crayon-nums " data-settings="show">
					<div class="urvanov-syntax-highlighter-nums-content" style="font-size: 12px !important; line-height: 15px !important;"><div class="crayon-num" data-line="urvanov-syntax-highlighter-62d9f14d16c59748952064-1">1</div><div class="crayon-num crayon-striped-num" data-line="urvanov-syntax-highlighter-62d9f14d16c59748952064-2">2</div><div class="crayon-num" data-line="urvanov-syntax-highlighter-62d9f14d16c59748952064-3">3</div></div>
				</td>
						<td class="urvanov-syntax-highlighter-code"><div class="crayon-pre" style="font-size: 12px !important; line-height: 15px !important; -moz-tab-size:4; -o-tab-size:4; -webkit-tab-size:4; tab-size:4;"><div class="crayon-line" id="urvanov-syntax-highlighter-62d9f14d16c59748952064-1"><span class="crayon-e">CREATE </span><span class="crayon-e">CLUSTERED </span><span class="crayon-e">COLUMNSTORE </span><span class="crayon-e">INDEX </span><span class="crayon-e">CCI</span></div><div class="crayon-line crayon-striped-line" id="urvanov-syntax-highlighter-62d9f14d16c59748952064-2"><span class="crayon-e">ON </span><span class="crayon-v">dbo</span><span class="crayon-sy">.</span><span class="crayon-e">Users_columnstore </span><span class="crayon-e">ORDER</span><span class="crayon-h"> </span><span class="crayon-sy">(</span><span class="crayon-v">Id</span><span class="crayon-sy">)</span></div><div class="crayon-line" id="urvanov-syntax-highlighter-62d9f14d16c59748952064-3"><span class="crayon-e">WITH</span><span class="crayon-h"> </span><span class="crayon-sy">(</span><span class="crayon-v">DROP_EXISTING</span><span class="crayon-h"> </span><span class="crayon-o">=</span><span class="crayon-h"> </span><span class="crayon-v">ON</span><span class="crayon-sy">)</span><span class="crayon-sy">;</span></div></div></td>
					</tr>
				</table>
			</div>
		</div>
<!-- [Format Time: 0.0001 seconds] -->
<p>
Rejoice! The data is now sorted by Id, so if you&#8217;re looking for a particular Id, SQL Server can narrow its search down to just one rowgroup:</p>
<p><a  href="https://www.brentozar.com/wp-content/uploads/2022/07/maxdop_parallel.png"><img loading="lazy" class="alignnone size-us_600_0 wp-image-348678" src="https://www.brentozar.com/wp-content/uploads/2022/07/maxdop_parallel-600x312.png" alt="" width="600" height="312" srcset="https://www.brentozar.com/wp-content/uploads/2022/07/maxdop_parallel-600x312.png 600w, https://www.brentozar.com/wp-content/uploads/2022/07/maxdop_parallel-250x130.png 250w, https://www.brentozar.com/wp-content/uploads/2022/07/maxdop_parallel.png 750w" sizes="(max-width: 600px) 100vw, 600px" /></a></p>
<p>Okay, I lied. It&#8217;s still not aligned. In fact, if anything, it&#8217;s even <em>worse</em>. You might argue that it&#8217;s because I didn&#8217;t specify a single-threaded index creation, but&#8230;those ranges overlap across <em>lots</em> of rowgroups, not just the 4 to represent the 4 cores in my VM.</p>
<p>When I try it again with MAXDOP 1:</p>
<p><a  href="https://www.brentozar.com/wp-content/uploads/2022/07/maxdop_1.png"><img loading="lazy" class="alignnone size-us_600_0 wp-image-348679" src="https://www.brentozar.com/wp-content/uploads/2022/07/maxdop_1-600x348.png" alt="" width="600" height="348" srcset="https://www.brentozar.com/wp-content/uploads/2022/07/maxdop_1-600x348.png 600w, https://www.brentozar.com/wp-content/uploads/2022/07/maxdop_1-250x145.png 250w, https://www.brentozar.com/wp-content/uploads/2022/07/maxdop_1.png 699w" sizes="(max-width: 600px) 100vw, 600px" /></a></p>
<p>That doesn&#8217;t work either, and even if it did, MAXDOP 1 isn&#8217;t really doable in real-world table sizes &#8211; even the 1GB Users table took over a minute to do the above work.</p>
<p>In theory, when the feature finally works, it&#8217;d be useful if many of your reporting queries share a common filter &#8211; like in data warehouses, a SaleDate column. Again, definitely doesn&#8217;t make sense for the Users table &#8211; it&#8217;s not a good fit for columnstore at all &#8211; but it does fix the problem of the data being randomly ordered between rowgroups.</p>
<p>When examining your own data and reporting queries to figure out which column(s) to order by, <a href="https://docs.microsoft.com/en-us/azure/synapse-analytics/sql-data-warehouse/performance-tuning-ordered-cci">check out the guidance for Synapse Analytics</a>, which already has this feature. And I assume it actually works out there. Although you know what they say about assume&#8230;</p>
<p><em><strong>Update 1, 2022-07-05:</strong> the command actually executes in CTP 2.0 when you use the right syntax, as pointed out by Adam Machanic in the comments.</em></p>
<h3>Update 2, 2022-07-05: no, it doesn&#8217;t work.</h3>
<p>Based on suggestions by Joe Obbish in the comments, I spent hours today trying repeated testing with columnstore indexes on tables up to 100GB on a VM with 30GB RAM. I even tried with MAXDOP 1, and still no dice &#8211; they&#8217;re not sorted:</p>
<p><a  href="https://www.brentozar.com/wp-content/uploads/2022/07/posts_by_creationdate.png"><img loading="lazy" class="alignnone size-us_600_0 wp-image-348680" src="https://www.brentozar.com/wp-content/uploads/2022/07/posts_by_creationdate-600x351.png" alt="" width="600" height="351" srcset="https://www.brentozar.com/wp-content/uploads/2022/07/posts_by_creationdate-600x351.png 600w, https://www.brentozar.com/wp-content/uploads/2022/07/posts_by_creationdate-250x146.png 250w, https://www.brentozar.com/wp-content/uploads/2022/07/posts_by_creationdate-768x450.png 768w, https://www.brentozar.com/wp-content/uploads/2022/07/posts_by_creationdate.png 772w" sizes="(max-width: 600px) 100vw, 600px" /></a></p>
<p>Note the overlap in CreationDate ranges. I give up &#8211; until Microsoft has a demo showing this feature actually works, I&#8217;m going to hold off on further testing.</p>
<h3>Update 3, 2022-07-11: it kinda works.</h3>
<p>Ryan Stonecipher (Microsoft) reached out to me and we talked through it.</p>
<p>The data is <em>kinda</em> sorted, and they&#8217;re referring to it as a &#8220;soft sort.&#8221; The sort order is maintained in-memory as the index is being built, but if the sort runs out of memory, the currently sorted data is flushed to the next operator in the index build plan. Joe Obbish reverse engineered this in <a href="https://www.erikdarlingdata.com/sql-server/ordered-columnstore-indexes-on-sql-server-2022-ctp-2-0/">this well-written blog post</a>.</p>
<p>The benefit of this design decision is that it avoids spilling to TempDB &#8211; that&#8217;s good.</p>
<p>The drawback is that the rowgroups aren&#8217;t perfectly sorted. There are going to be overlaps between rowgroups. The idea is just that there&#8217;s going to be way <em>less</em> overlaps than there would be with a completely unsorted set of rowgroups.</p>
<p>I&#8217;m totally fine with this. At the end of the day, it&#8217;s way better than the ALTER INDEX REBUILD behavior of columnstore, except for the fact that it&#8217;s offline only. The docs just need to better reflect that &#8220;order&#8221; is a best effort thing, not the kind of exact stuff that we usually expect from databases. I kinda jokingly think of it as a MongoDB simulator.</p>
</div></div></div></div></div></div></section><section class="l-section wpb_row height_auto"><div class="l-section-h i-cf"><div class="g-cols vc_row via_flex valign_top type_default stacking_default"><div class="vc_col-sm-12 wpb_column vc_column_container"><div class="vc_column-inner"><div class="wpb_wrapper"><div class="w-post-elm post_navigation layout_simple inv_false"><a class="post_navigation-item order_first to_prev" href="https://www.brentozar.com/archive/2022/06/video-office-hours-professional-development-questions/" title="[Video] Office Hours: Professional Development Questions"><div class="post_navigation-item-arrow"></div><div class="post_navigation-item-meta">Previous Post</div><div class="post_navigation-item-title"><span>[Video] Office Hours: Professional Development Questions</span></div></a><a class="post_navigation-item order_second to_next" href="https://www.brentozar.com/archive/2022/07/whos-hiring-in-the-database-community-july-2022-edition/" title="Who&#8217;s Hiring in the Database Community? July 2022 Edition"><div class="post_navigation-item-arrow"></div><div class="post_navigation-item-meta">Next Post</div><div class="post_navigation-item-title"><span>Who&#8217;s Hiring in the Database Community? July 2022 Edition</span></div></a></div><div class="w-separator size_small with_line width_default thick_1 style_solid color_border align_center"><div class="w-separator-h"></div></div><div class="w-post-elm post_comments layout_comments_template"><div id="comments" class="w-comments">
			<h4 class="w-comments-title">
			<span>20 <span class="screen-reader-text">Comments</span>.</span> <a href="#respond">Leave new</a>		</h4>

		<ul class="w-comments-list">
					<li class="comment even thread-even depth-1 w-comments-item" id="comment-3578336">
			<div class="w-comments-item-meta">
				<img alt='' src='https://secure.gravatar.com/avatar/2d6e491fa773660aff4414c84be25579?s=50&#038;d=wavatar&#038;r=r' srcset='https://secure.gravatar.com/avatar/2d6e491fa773660aff4414c84be25579?s=100&#038;d=wavatar&#038;r=r 2x' class='avatar avatar-50 photo' height='50' width='50' loading='lazy'/>				<div class="w-comments-item-author">
										<span>Adam Machanic</span>
									</div>
				<a class="w-comments-item-date smooth-scroll" href="#comment-3578336">July 5, 2022 2:25 pm</a>
			</div>
			<div class="w-comments-item-text">
				<p>Per the documentation it&#8217;s supposed to have an &#8220;ORDER&#8221; keyword for the column list. I&#8217;m not sure if that fixes your example? Also not clear to me why that&#8217;s not available for a nonclustered columnstore?</p>
			</div>

			<a rel='nofollow' class='comment-reply-link' href='#comment-3578336' data-commentid="3578336" data-postid="348666" data-belowelement="comment-3578336" data-respondelement="respond" data-replyto="Reply to Adam Machanic" aria-label='Reply to Adam Machanic'>Reply</a><ul class="children">
		<li class="comment byuser comment-author-brento bypostauthor odd alt depth-2 w-comments-item" id="comment-3578343">
			<div class="w-comments-item-meta">
				<img alt='' src='https://secure.gravatar.com/avatar/77f776c2eaf0cc691e8a0880bb8a191f?s=50&#038;d=wavatar&#038;r=r' srcset='https://secure.gravatar.com/avatar/77f776c2eaf0cc691e8a0880bb8a191f?s=100&#038;d=wavatar&#038;r=r 2x' class='avatar avatar-50 photo' height='50' width='50' loading='lazy'/>				<div class="w-comments-item-author">
					<a href="https://www.brentozar.com" target="_blank" rel="noopener nofollow">					<span>Brent Ozar</span>
					</a>				</div>
				<a class="w-comments-item-date smooth-scroll" href="#comment-3578343">July 5, 2022 2:45 pm</a>
			</div>
			<div class="w-comments-item-text">
				<p>Oh boy &#8211; well, thanks for the correction there in that with the right syntax, it executes &#8211; but it doesn&#8217;t work. I&#8217;ve updated the blog post with screenshots showing what a hot mess it is.</p>
			</div>

			<a rel='nofollow' class='comment-reply-link' href='#comment-3578343' data-commentid="3578343" data-postid="348666" data-belowelement="comment-3578343" data-respondelement="respond" data-replyto="Reply to Brent Ozar" aria-label='Reply to Brent Ozar'>Reply</a></li><!-- #comment-## -->
		<li class="comment even depth-2 w-comments-item" id="comment-3580917">
			<div class="w-comments-item-meta">
				<img alt='' src='https://secure.gravatar.com/avatar/99da5ed47376d99f04ccceecd96d7e1f?s=50&#038;d=wavatar&#038;r=r' srcset='https://secure.gravatar.com/avatar/99da5ed47376d99f04ccceecd96d7e1f?s=100&#038;d=wavatar&#038;r=r 2x' class='avatar avatar-50 photo' height='50' width='50' loading='lazy'/>				<div class="w-comments-item-author">
										<span>Gabriel</span>
									</div>
				<a class="w-comments-item-date smooth-scroll" href="#comment-3580917">July 15, 2022 9:11 pm</a>
			</div>
			<div class="w-comments-item-text">
				<p>Also disappointed this doesn&#8217;t apply to nonclustered columnstore and judging from the existing documentation, it looks like there&#8217;s no plan for it.</p>
			</div>

			<a rel='nofollow' class='comment-reply-link' href='#comment-3580917' data-commentid="3580917" data-postid="348666" data-belowelement="comment-3580917" data-respondelement="respond" data-replyto="Reply to Gabriel" aria-label='Reply to Gabriel'>Reply</a></li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
		<li class="comment odd alt thread-odd thread-alt depth-1 w-comments-item" id="comment-3578360">
			<div class="w-comments-item-meta">
				<img alt='' src='https://secure.gravatar.com/avatar/1bdfb0c99c74311e7c27924074c14ad3?s=50&#038;d=wavatar&#038;r=r' srcset='https://secure.gravatar.com/avatar/1bdfb0c99c74311e7c27924074c14ad3?s=100&#038;d=wavatar&#038;r=r 2x' class='avatar avatar-50 photo' height='50' width='50' loading='lazy'/>				<div class="w-comments-item-author">
										<span>Joe Obbish</span>
									</div>
				<a class="w-comments-item-date smooth-scroll" href="#comment-3578360">July 5, 2022 5:23 pm</a>
			</div>
			<div class="w-comments-item-text">
				<p>Hi Brent,</p>
<p>I haven&#8217;t personally tested this feature, but the following quote from the linked documentation may explain what you&#8217;re seeing with the overlapping segments: &#8220;If all data can be sorted in memory at once, then segment overlapping can be avoided. Due to large tables in data warehouses, this scenario doesn&#8217;t happen often.&#8221;</p>
<p>It&#8217;s hard not to roll my eyes at the last sentence but perhaps others are more forgiving than I am.</p>
			</div>

			<a rel='nofollow' class='comment-reply-link' href='#comment-3578360' data-commentid="3578360" data-postid="348666" data-belowelement="comment-3578360" data-respondelement="respond" data-replyto="Reply to Joe Obbish" aria-label='Reply to Joe Obbish'>Reply</a><ul class="children">
		<li class="comment even depth-2 w-comments-item" id="comment-3578362">
			<div class="w-comments-item-meta">
				<img alt='' src='https://secure.gravatar.com/avatar/ab68fefe14e2f72277e6f08796e50fbf?s=50&#038;d=wavatar&#038;r=r' srcset='https://secure.gravatar.com/avatar/ab68fefe14e2f72277e6f08796e50fbf?s=100&#038;d=wavatar&#038;r=r 2x' class='avatar avatar-50 photo' height='50' width='50' loading='lazy'/>				<div class="w-comments-item-author">
										<span>happydba</span>
									</div>
				<a class="w-comments-item-date smooth-scroll" href="#comment-3578362">July 5, 2022 5:32 pm</a>
			</div>
			<div class="w-comments-item-text">
				<p>Hmm I would love to know the criteria for &#8220;can be sorted in memory at once&#8221; &#8211; like, will it use up to the default query memory limit? 25% of memory? Or all of the memory, ejecting everything else from the data cache to do it? Or some other limit?</p>
			</div>

			<a rel='nofollow' class='comment-reply-link' href='#comment-3578362' data-commentid="3578362" data-postid="348666" data-belowelement="comment-3578362" data-respondelement="respond" data-replyto="Reply to happydba" aria-label='Reply to happydba'>Reply</a></li><!-- #comment-## -->
		<li class="comment byuser comment-author-brento bypostauthor odd alt depth-2 w-comments-item" id="comment-3578371">
			<div class="w-comments-item-meta">
				<img alt='' src='https://secure.gravatar.com/avatar/77f776c2eaf0cc691e8a0880bb8a191f?s=50&#038;d=wavatar&#038;r=r' srcset='https://secure.gravatar.com/avatar/77f776c2eaf0cc691e8a0880bb8a191f?s=100&#038;d=wavatar&#038;r=r 2x' class='avatar avatar-50 photo' height='50' width='50' loading='lazy'/>				<div class="w-comments-item-author">
					<a href="https://www.brentozar.com" target="_blank" rel="noopener nofollow">					<span>Brent Ozar</span>
					</a>				</div>
				<a class="w-comments-item-date smooth-scroll" href="#comment-3578371">July 5, 2022 6:14 pm</a>
			</div>
			<div class="w-comments-item-text">
				<p>Hoo boy &#8211; doesn&#8217;t happen often, here we go.</p>
<p>I tried it with the Votes table &#8211; 150M rows, 5GB uncompressed, 1.3GB columnstore &#8211; on a VM with 30GB RAM, 25GB max. Not large enough &#8211; same problem.</p>
<p>Now testing it with the Posts table (40M rows, 80GB uncompressed, only using the left 1000 characters of the Body column) but it&#8217;s taking forever (30 minutes and counting). (sigh)</p>
			</div>

			<a rel='nofollow' class='comment-reply-link' href='#comment-3578371' data-commentid="3578371" data-postid="348666" data-belowelement="comment-3578371" data-respondelement="respond" data-replyto="Reply to Brent Ozar" aria-label='Reply to Brent Ozar'>Reply</a><ul class="children">
		<li class="comment even depth-3 w-comments-item" id="comment-3578574">
			<div class="w-comments-item-meta">
				<img alt='' src='https://secure.gravatar.com/avatar/ab68fefe14e2f72277e6f08796e50fbf?s=50&#038;d=wavatar&#038;r=r' srcset='https://secure.gravatar.com/avatar/ab68fefe14e2f72277e6f08796e50fbf?s=100&#038;d=wavatar&#038;r=r 2x' class='avatar avatar-50 photo' height='50' width='50' loading='lazy'/>				<div class="w-comments-item-author">
										<span>happydba</span>
									</div>
				<a class="w-comments-item-date smooth-scroll" href="#comment-3578574">July 6, 2022 3:08 pm</a>
			</div>
			<div class="w-comments-item-text">
				<p>That&#8217;s disappointing 🙁 For sure thank you for testing that though!</p>
			</div>

			<a rel='nofollow' class='comment-reply-link' href='#comment-3578574' data-commentid="3578574" data-postid="348666" data-belowelement="comment-3578574" data-respondelement="respond" data-replyto="Reply to happydba" aria-label='Reply to happydba'>Reply</a></li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
		<li class="comment byuser comment-author-brento bypostauthor odd alt depth-2 w-comments-item" id="comment-3578393">
			<div class="w-comments-item-meta">
				<img alt='' src='https://secure.gravatar.com/avatar/77f776c2eaf0cc691e8a0880bb8a191f?s=50&#038;d=wavatar&#038;r=r' srcset='https://secure.gravatar.com/avatar/77f776c2eaf0cc691e8a0880bb8a191f?s=100&#038;d=wavatar&#038;r=r 2x' class='avatar avatar-50 photo' height='50' width='50' loading='lazy'/>				<div class="w-comments-item-author">
					<a href="https://www.brentozar.com" target="_blank" rel="noopener nofollow">					<span>Brent Ozar</span>
					</a>				</div>
				<a class="w-comments-item-date smooth-scroll" href="#comment-3578393">July 5, 2022 8:30 pm</a>
			</div>
			<div class="w-comments-item-text">
				<p>Bad news &#8211; it doesn&#8217;t work, even with the Posts table, even with MAXDOP 1. Updated the post to reflect it. Dang.</p>
			</div>

			<a rel='nofollow' class='comment-reply-link' href='#comment-3578393' data-commentid="3578393" data-postid="348666" data-belowelement="comment-3578393" data-respondelement="respond" data-replyto="Reply to Brent Ozar" aria-label='Reply to Brent Ozar'>Reply</a><ul class="children">
		<li class="comment even depth-3 w-comments-item" id="comment-3578643">
			<div class="w-comments-item-meta">
				<img alt='' src='https://secure.gravatar.com/avatar/ab68fefe14e2f72277e6f08796e50fbf?s=50&#038;d=wavatar&#038;r=r' srcset='https://secure.gravatar.com/avatar/ab68fefe14e2f72277e6f08796e50fbf?s=100&#038;d=wavatar&#038;r=r 2x' class='avatar avatar-50 photo' height='50' width='50' loading='lazy'/>				<div class="w-comments-item-author">
										<span>happydba</span>
									</div>
				<a class="w-comments-item-date smooth-scroll" href="#comment-3578643">July 6, 2022 6:05 pm</a>
			</div>
			<div class="w-comments-item-text">
				<p>I wonder if this is affecting the test and it&#8217;s just not telling you it&#8217;s not using the MAXDOP = 1 option &#8211; from:</p>
<p><a href="https://docs.microsoft.com/en-us/azure/synapse-analytics/sql-data-warehouse/performance-tuning-ordered-cci" rel="nofollow ugc">https://docs.microsoft.com/en-us/azure/synapse-analytics/sql-data-warehouse/performance-tuning-ordered-cci</a></p>
<p>&#8220;Currently, the MAXDOP option is only supported in creating an ordered CCI table using CREATE TABLE AS SELECT command. Creating an ordered CCI via CREATE INDEX or CREATE TABLE commands does not support the MAXDOP option. For example, </p>
<p>CREATE TABLE Table1 WITH (DISTRIBUTION = HASH(c1), CLUSTERED COLUMNSTORE INDEX ORDER(c1) )<br />
AS SELECT * FROM ExampleTable<br />
OPTION (MAXDOP 1);&#8221;</p>
			</div>

			<a rel='nofollow' class='comment-reply-link' href='#comment-3578643' data-commentid="3578643" data-postid="348666" data-belowelement="comment-3578643" data-respondelement="respond" data-replyto="Reply to happydba" aria-label='Reply to happydba'>Reply</a><ul class="children">
		<li class="comment odd alt depth-4 w-comments-item" id="comment-3578645">
			<div class="w-comments-item-meta">
				<img alt='' src='https://secure.gravatar.com/avatar/ab68fefe14e2f72277e6f08796e50fbf?s=50&#038;d=wavatar&#038;r=r' srcset='https://secure.gravatar.com/avatar/ab68fefe14e2f72277e6f08796e50fbf?s=100&#038;d=wavatar&#038;r=r 2x' class='avatar avatar-50 photo' height='50' width='50' loading='lazy'/>				<div class="w-comments-item-author">
										<span>happydba</span>
									</div>
				<a class="w-comments-item-date smooth-scroll" href="#comment-3578645">July 6, 2022 6:08 pm</a>
			</div>
			<div class="w-comments-item-text">
				<p>As in &#8211; it should throw an error or warning that it won&#8217;t use the MAXDOP option specified, but since it&#8217;s CTP it a bug that it&#8217;s not warning you</p>
			</div>

			<a rel='nofollow' class='comment-reply-link' href='#comment-3578645' data-commentid="3578645" data-postid="348666" data-belowelement="comment-3578645" data-respondelement="respond" data-replyto="Reply to happydba" aria-label='Reply to happydba'>Reply</a></li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
		<li class="comment byuser comment-author-craig1 even thread-even depth-1 w-comments-item" id="comment-3578395">
			<div class="w-comments-item-meta">
				<img alt='' src='https://secure.gravatar.com/avatar/a0b54e9d30a3037708ac2d244bf9b934?s=50&#038;d=wavatar&#038;r=r' srcset='https://secure.gravatar.com/avatar/a0b54e9d30a3037708ac2d244bf9b934?s=100&#038;d=wavatar&#038;r=r 2x' class='avatar avatar-50 photo' height='50' width='50' loading='lazy'/>				<div class="w-comments-item-author">
										<span>Craig</span>
									</div>
				<a class="w-comments-item-date smooth-scroll" href="#comment-3578395">July 5, 2022 8:40 pm</a>
			</div>
			<div class="w-comments-item-text">
				<p>I was so excited when I started reading this post, but what a disappointment. Let’s hope by RTM it’s sorted</p>
			</div>

			<a rel='nofollow' class='comment-reply-link' href='#comment-3578395' data-commentid="3578395" data-postid="348666" data-belowelement="comment-3578395" data-respondelement="respond" data-replyto="Reply to Craig" aria-label='Reply to Craig'>Reply</a><ul class="children">
		<li class="comment odd alt depth-2 w-comments-item" id="comment-3579341">
			<div class="w-comments-item-meta">
				<img alt='' src='https://secure.gravatar.com/avatar/2d6e491fa773660aff4414c84be25579?s=50&#038;d=wavatar&#038;r=r' srcset='https://secure.gravatar.com/avatar/2d6e491fa773660aff4414c84be25579?s=100&#038;d=wavatar&#038;r=r 2x' class='avatar avatar-50 photo' height='50' width='50' loading='lazy'/>				<div class="w-comments-item-author">
										<span>Adam Machanic</span>
									</div>
				<a class="w-comments-item-date smooth-scroll" href="#comment-3579341">July 9, 2022 1:29 am</a>
			</div>
			<div class="w-comments-item-text">
				<p>Pun intended???</p>
			</div>

			<a rel='nofollow' class='comment-reply-link' href='#comment-3579341' data-commentid="3579341" data-postid="348666" data-belowelement="comment-3579341" data-respondelement="respond" data-replyto="Reply to Adam Machanic" aria-label='Reply to Adam Machanic'>Reply</a></li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
		<li class="comment even thread-odd thread-alt depth-1 w-comments-item" id="comment-3578498">
			<div class="w-comments-item-meta">
				<img alt='' src='https://secure.gravatar.com/avatar/31ba9370f695d9c69afd8696152f4922?s=50&#038;d=wavatar&#038;r=r' srcset='https://secure.gravatar.com/avatar/31ba9370f695d9c69afd8696152f4922?s=100&#038;d=wavatar&#038;r=r 2x' class='avatar avatar-50 photo' height='50' width='50' loading='lazy'/>				<div class="w-comments-item-author">
										<span>jkibicki</span>
									</div>
				<a class="w-comments-item-date smooth-scroll" href="#comment-3578498">July 6, 2022 7:21 am</a>
			</div>
			<div class="w-comments-item-text">
				<p>I have some questions:</p>
<p>1. Is it already on AzureSQL? Or when it will be?<br />
2. Brent, I have a feeling that you intentionally omitted the topic of partitioning columnstore index tables. Partitioning provides similar feature to dividing / sorting table into pieces.<br />
3. I am wondering if REBUILD will be more resource consuming operation since it will require to sort all data across table/partition. What do you think about it?</p>
			</div>

			<a rel='nofollow' class='comment-reply-link' href='#comment-3578498' data-commentid="3578498" data-postid="348666" data-belowelement="comment-3578498" data-respondelement="respond" data-replyto="Reply to jkibicki" aria-label='Reply to jkibicki'>Reply</a><ul class="children">
		<li class="comment byuser comment-author-brento bypostauthor odd alt depth-2 w-comments-item" id="comment-3578500">
			<div class="w-comments-item-meta">
				<img alt='' src='https://secure.gravatar.com/avatar/77f776c2eaf0cc691e8a0880bb8a191f?s=50&#038;d=wavatar&#038;r=r' srcset='https://secure.gravatar.com/avatar/77f776c2eaf0cc691e8a0880bb8a191f?s=100&#038;d=wavatar&#038;r=r 2x' class='avatar avatar-50 photo' height='50' width='50' loading='lazy'/>				<div class="w-comments-item-author">
					<a href="https://www.brentozar.com" target="_blank" rel="noopener nofollow">					<span>Brent Ozar</span>
					</a>				</div>
				<a class="w-comments-item-date smooth-scroll" href="#comment-3578500">July 6, 2022 7:23 am</a>
			</div>
			<div class="w-comments-item-text">
				<p>1. No.</p>
<p>2. I have a feeling you didn&#8217;t read the post, or even bother to do a control-F for &#8220;partition&#8221;. And that&#8217;s where I stop reading your comment.</p>
			</div>

			<a rel='nofollow' class='comment-reply-link' href='#comment-3578500' data-commentid="3578500" data-postid="348666" data-belowelement="comment-3578500" data-respondelement="respond" data-replyto="Reply to Brent Ozar" aria-label='Reply to Brent Ozar'>Reply</a></li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
		<li class="comment byuser comment-author-artur-bukowski even thread-even depth-1 w-comments-item" id="comment-3578634">
			<div class="w-comments-item-meta">
				<img alt='' src='https://secure.gravatar.com/avatar/98554b8eb8cb49ee49259333c5652f42?s=50&#038;d=wavatar&#038;r=r' srcset='https://secure.gravatar.com/avatar/98554b8eb8cb49ee49259333c5652f42?s=100&#038;d=wavatar&#038;r=r 2x' class='avatar avatar-50 photo' height='50' width='50' loading='lazy'/>				<div class="w-comments-item-author">
										<span>Artur Bukowski</span>
									</div>
				<a class="w-comments-item-date smooth-scroll" href="#comment-3578634">July 6, 2022 5:42 pm</a>
			</div>
			<div class="w-comments-item-text">
				<p>If this was the only feature (fixed of course and working as expected) added to SQL Server 2022 I bet lots of shops running Data Warehouses would upgrade only to improve querying and maintenance of big data!</p>
<p>By the way, Niko Neugebauer was giving it (ORDER) a try in Azure in 2019:<br />
<a href="https://www.nikoport.com/2019/10/04/columnstore-indexes-part-128-ordering-columnstore-in-azure-sqldw/" rel="nofollow ugc">https://www.nikoport.com/2019/10/04/columnstore-indexes-part-128-ordering-columnstore-in-azure-sqldw/</a><br />
tuning it with Extra Large Resource Role (xlargerc) achieving even 100% allignment.</p>
			</div>

			<a rel='nofollow' class='comment-reply-link' href='#comment-3578634' data-commentid="3578634" data-postid="348666" data-belowelement="comment-3578634" data-respondelement="respond" data-replyto="Reply to Artur Bukowski" aria-label='Reply to Artur Bukowski'>Reply</a><ul class="children">
		<li class="comment odd alt depth-2 w-comments-item" id="comment-3578742">
			<div class="w-comments-item-meta">
				<img alt='' src='https://secure.gravatar.com/avatar/cefee6a52c820dbe6903479ea7dad57e?s=50&#038;d=wavatar&#038;r=r' srcset='https://secure.gravatar.com/avatar/cefee6a52c820dbe6903479ea7dad57e?s=100&#038;d=wavatar&#038;r=r 2x' class='avatar avatar-50 photo' height='50' width='50' loading='lazy'/>				<div class="w-comments-item-author">
										<span>Saxman</span>
									</div>
				<a class="w-comments-item-date smooth-scroll" href="#comment-3578742">July 7, 2022 12:31 am</a>
			</div>
			<div class="w-comments-item-text">
				<p>Note:  that URL doesn&#8217;t make browsers happy&#8230;.not sure what&#8217;s going on there&#8230;.it says its potential security risk&#8230;most curious</p>
			</div>

			<a rel='nofollow' class='comment-reply-link' href='#comment-3578742' data-commentid="3578742" data-postid="348666" data-belowelement="comment-3578742" data-respondelement="respond" data-replyto="Reply to Saxman" aria-label='Reply to Saxman'>Reply</a><ul class="children">
		<li class="comment byuser comment-author-brento bypostauthor even depth-3 w-comments-item" id="comment-3578795">
			<div class="w-comments-item-meta">
				<img alt='' src='https://secure.gravatar.com/avatar/77f776c2eaf0cc691e8a0880bb8a191f?s=50&#038;d=wavatar&#038;r=r' srcset='https://secure.gravatar.com/avatar/77f776c2eaf0cc691e8a0880bb8a191f?s=100&#038;d=wavatar&#038;r=r 2x' class='avatar avatar-50 photo' height='50' width='50' loading='lazy'/>				<div class="w-comments-item-author">
					<a href="https://www.brentozar.com" target="_blank" rel="noopener nofollow">					<span>Brent Ozar</span>
					</a>				</div>
				<a class="w-comments-item-date smooth-scroll" href="#comment-3578795">July 7, 2022 7:11 am</a>
			</div>
			<div class="w-comments-item-text">
				<p>Niko has an SSL certificate configuration problem.</p>
			</div>

			<a rel='nofollow' class='comment-reply-link' href='#comment-3578795' data-commentid="3578795" data-postid="348666" data-belowelement="comment-3578795" data-respondelement="respond" data-replyto="Reply to Brent Ozar" aria-label='Reply to Brent Ozar'>Reply</a><ul class="children">
		<li class="comment odd alt depth-4 w-comments-item" id="comment-3581847">
			<div class="w-comments-item-meta">
				<img alt='' src='https://secure.gravatar.com/avatar/d1693ba8925efb393b15a15207bc1558?s=50&#038;d=wavatar&#038;r=r' srcset='https://secure.gravatar.com/avatar/d1693ba8925efb393b15a15207bc1558?s=100&#038;d=wavatar&#038;r=r 2x' class='avatar avatar-50 photo' height='50' width='50' loading='lazy'/>				<div class="w-comments-item-author">
										<span>Thomas Franz</span>
									</div>
				<a class="w-comments-item-date smooth-scroll" href="#comment-3581847">July 20, 2022 10:28 am</a>
			</div>
			<div class="w-comments-item-text">
				<p>Niko sadly seems to have stopped working on his page 2 or 3 years ago. There is other stuff that no longer works and I tried once to contact him, but he didn&#8217;t reply. And there are no new / updated posts.</p>
			</div>

			<a rel='nofollow' class='comment-reply-link' href='#comment-3581847' data-commentid="3581847" data-postid="348666" data-belowelement="comment-3581847" data-respondelement="respond" data-replyto="Reply to Thomas Franz" aria-label='Reply to Thomas Franz'>Reply</a></li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
		<li class="comment even thread-odd thread-alt depth-1 w-comments-item" id="comment-3581849">
			<div class="w-comments-item-meta">
				<img alt='' src='https://secure.gravatar.com/avatar/d1693ba8925efb393b15a15207bc1558?s=50&#038;d=wavatar&#038;r=r' srcset='https://secure.gravatar.com/avatar/d1693ba8925efb393b15a15207bc1558?s=100&#038;d=wavatar&#038;r=r 2x' class='avatar avatar-50 photo' height='50' width='50' loading='lazy'/>				<div class="w-comments-item-author">
										<span>Thomas Franz</span>
									</div>
				<a class="w-comments-item-date smooth-scroll" href="#comment-3581849">July 20, 2022 10:40 am</a>
			</div>
			<div class="w-comments-item-text">
				<p>I&#8217;d assume that specifiying an explicit ORDER to a columnstore would decrease the compression ratio / increases the columnstore size.</p>
<p>As far I remember the common clustered columnstore tries to order the columns for best compression (= most repeats in (multiple) columns, so it may order a user table by country, first_name and city, because there may be MANY Bobs and Marys in New York / USA)</p>
			</div>

			<a rel='nofollow' class='comment-reply-link' href='#comment-3581849' data-commentid="3581849" data-postid="348666" data-belowelement="comment-3581849" data-respondelement="respond" data-replyto="Reply to Thomas Franz" aria-label='Reply to Thomas Franz'>Reply</a><ul class="children">
		<li class="comment byuser comment-author-brento bypostauthor odd alt depth-2 w-comments-item" id="comment-3581879">
			<div class="w-comments-item-meta">
				<img alt='' src='https://secure.gravatar.com/avatar/77f776c2eaf0cc691e8a0880bb8a191f?s=50&#038;d=wavatar&#038;r=r' srcset='https://secure.gravatar.com/avatar/77f776c2eaf0cc691e8a0880bb8a191f?s=100&#038;d=wavatar&#038;r=r 2x' class='avatar avatar-50 photo' height='50' width='50' loading='lazy'/>				<div class="w-comments-item-author">
					<a href="https://www.brentozar.com" target="_blank" rel="noopener nofollow">					<span>Brent Ozar</span>
					</a>				</div>
				<a class="w-comments-item-date smooth-scroll" href="#comment-3581879">July 20, 2022 3:02 pm</a>
			</div>
			<div class="w-comments-item-text">
				<p>You’re on the right track, but not quite right. I explain how the internals ordering works in my Fundamentals of Columnstore class, but it’s beyond what I can do quickly in a comment here. Check it out!</p>
			</div>

			<a rel='nofollow' class='comment-reply-link' href='#comment-3581879' data-commentid="3581879" data-postid="348666" data-belowelement="comment-3581879" data-respondelement="respond" data-replyto="Reply to Brent Ozar" aria-label='Reply to Brent Ozar'>Reply</a></li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
		</ul>

		<div class="w-comments-pagination">
								</div>
	
		<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/archive/2022/07/columnstore-indexes-are-finally-sorted-in-sql-server-2022/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://www.brentozar.com/wp-comments-post.php?wpe-comment-post=brentozarultd" method="post" id="commentform" class="comment-form" novalidate><p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> <span class="required-field-message" aria-hidden="true">Required fields are marked <span class="required" aria-hidden="true">*</span></span></p><div class="w-form-row for_textarea required">
		<div class="w-form-row-field">
						<textarea aria-label="Comment" name="comment" placeholder="Comment *" data-required="true" aria-required="true"></textarea>
			</div>
		<div class="w-form-row-state">Fill out this field</div>
</div>
<div class="w-form-row for_text required">
		<div class="w-form-row-field">
						<input aria-label="Name" type="text" name="author" value placeholder="Name *" data-required="true" aria-required="true"/>
			</div>
		<div class="w-form-row-state">Fill out this field</div>
</div>

<div class="w-form-row for_email required">
		<div class="w-form-row-field">
						<input aria-label="Email" type="email" name="email" value placeholder="Email *" data-required="true" aria-required="true"/>
			</div>
		<div class="w-form-row-state">Please enter a valid email address.</div>
</div>

<p class="form-submit"><button type="submit" class="w-btn us-btn-style_1"><span class="w-btn-label">Post Comment</span></button> <input type='hidden' name='comment_post_ID' value='348666' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="ec58e22d58" /></p><p style="display: none !important;"><label>&#916;<textarea name="ak_hp_textarea" cols="45" rows="8" maxlength="100"></textarea></label><input type="hidden" id="ak_js_1" name="ak_js" value="99"/><script>document.getElementById( "ak_js_1" ).setAttribute( "value", ( new Date() ).getTime() );</script></p></form>	</div><!-- #respond -->
	<div class="us-comments-json hidden" onclick='return {&quot;no_content_msg&quot;:&quot;Fill out this field&quot;,&quot;no_name_msg&quot;:&quot;Fill out this field&quot;,&quot;no_email_msg&quot;:&quot;Please enter a valid email address.&quot;}'></div></div>
</div><div class="w-separator size_large"></div></div></div></div></div></div></section>
</div></div><div class="l-sidebar"><div class="vc_column-inner"><div id="block-6" class="widget widget_block widget_media_image">
<figure class="wp-block-image size-full"><img loading="lazy" width="274" height="300" src="https://www.brentozar.com/wp-content/uploads/2019/01/Brent-Ozar-with-Coffee-275.png" alt="Brent Ozar" class="wp-image-200511" srcset="https://www.brentozar.com/wp-content/uploads/2019/01/Brent-Ozar-with-Coffee-275.png 274w, https://www.brentozar.com/wp-content/uploads/2019/01/Brent-Ozar-with-Coffee-275-183x200.png 183w" sizes="(max-width: 274px) 100vw, 274px" /></figure>
</div><div id="text-2" class="widget widget_text"><h3 class="widgettitle">Hi! I&#8217;m Brent Ozar.</h3>			<div class="textwidget"><p>I make Microsoft SQL Server go faster. I love teaching, travel, cars, and laughing. I&#8217;m based out of Las Vegas. He/him. I teach <a href="https://www.brentozar.com/training/">SQL Server training classes</a>, or if you haven&#8217;t got time for the pain, I&#8217;m <a href="https://www.brentozar.com/sql-critical-care/">available for consulting</a> too.</p>
<p>Want to <a href="https://www.brentozar.com/product/sponsorship/">advertise here</a> and reach my savvy readers?</p>
</div>
		</div><div id="gform_widget-2" class="widget gform_widget"><link rel='stylesheet' id='gforms_reset_css-css'  href='https://www.brentozar.com/wp-content/plugins/gravityforms/legacy/css/formreset.min.css?ver=2.6.4' media='all' />
<link rel='stylesheet' id='gforms_formsmain_css-css'  href='https://www.brentozar.com/wp-content/plugins/gravityforms/legacy/css/formsmain.min.css?ver=2.6.4' media='all' />
<link rel='stylesheet' id='gforms_ready_class_css-css'  href='https://www.brentozar.com/wp-content/plugins/gravityforms/legacy/css/readyclass.min.css?ver=2.6.4' media='all' />
<link rel='stylesheet' id='gforms_browsers_css-css'  href='https://www.brentozar.com/wp-content/plugins/gravityforms/legacy/css/browsers.min.css?ver=2.6.4' media='all' />
<script src='https://www.brentozar.com/wp-includes/js/dist/vendor/regenerator-runtime.min.js?ver=0.13.9' id='regenerator-runtime-js'></script>
<script src='https://www.brentozar.com/wp-includes/js/dist/vendor/wp-polyfill.min.js?ver=3.15.0' id='wp-polyfill-js'></script>
<script src='https://www.brentozar.com/wp-includes/js/dist/dom-ready.min.js?ver=d996b53411d1533a84951212ab6ac4ff' id='wp-dom-ready-js'></script>
<script src='https://www.brentozar.com/wp-includes/js/dist/hooks.min.js?ver=c6d64f2cb8f5c6bb49caca37f8828ce3' id='wp-hooks-js'></script>
<script src='https://www.brentozar.com/wp-includes/js/dist/i18n.min.js?ver=ebee46757c6a411e38fd079a7ac71d94' id='wp-i18n-js'></script>
<script id='wp-i18n-js-after'>
wp.i18n.setLocaleData( { 'text direction\u0004ltr': [ 'ltr' ] } );
</script>
<script src='https://www.brentozar.com/wp-includes/js/dist/a11y.min.js?ver=a38319d7ba46c6e60f7f9d4c371222c5' id='wp-a11y-js'></script>
<script defer='defer' src='https://www.brentozar.com/wp-content/plugins/gravityforms/js/jquery.json.min.js?ver=2.6.4' id='gform_json-js'></script>
<script id='gform_gravityforms-js-extra'>
var gform_i18n = {"datepicker":{"days":{"monday":"Mon","tuesday":"Tue","wednesday":"Wed","thursday":"Thu","friday":"Fri","saturday":"Sat","sunday":"Sun"},"months":{"january":"January","february":"February","march":"March","april":"April","may":"May","june":"June","july":"July","august":"August","september":"September","october":"October","november":"November","december":"December"},"firstDay":0,"iconText":"Select date"}};
var gf_legacy_multi = [];
var gform_gravityforms = {"strings":{"invalid_file_extension":"This type of file is not allowed. Must be one of the following:","delete_file":"Delete this file","in_progress":"in progress","file_exceeds_limit":"File exceeds size limit","illegal_extension":"This type of file is not allowed.","max_reached":"Maximum number of files reached","unknown_error":"There was a problem while saving the file on the server","currently_uploading":"Please wait for the uploading to complete","cancel":"Cancel","cancel_upload":"Cancel this upload","cancelled":"Cancelled"},"vars":{"images_url":"https:\/\/www.brentozar.com\/wp-content\/plugins\/gravityforms\/images"}};
var gf_global = {"gf_currency_config":{"name":"U.S. Dollar","symbol_left":"$","symbol_right":"","symbol_padding":"","thousand_separator":",","decimal_separator":".","decimals":2,"code":"USD"},"base_url":"https:\/\/www.brentozar.com\/wp-content\/plugins\/gravityforms","number_formats":[],"spinnerUrl":"https:\/\/www.brentozar.com\/wp-content\/plugins\/gravityforms\/images\/spinner.svg","strings":{"newRowAdded":"New row added.","rowRemoved":"Row removed","formSaved":"The form has been saved.  The content contains the link to return and complete the form."}};
</script>
<script defer='defer' src='https://www.brentozar.com/wp-content/plugins/gravityforms/js/gravityforms.min.js?ver=2.6.4' id='gform_gravityforms-js'></script>
<script type="text/javascript"></script>
                <div class='gf_browser_gecko gform_wrapper gform_legacy_markup_wrapper' id='gform_wrapper_35' ><div id='gf_35' class='gform_anchor' tabindex='-1'></div><form method='post' enctype='multipart/form-data' target='gform_ajax_frame_35' id='gform_35'  action='/archive/2022/07/columnstore-indexes-are-finally-sorted-in-sql-server-2022/#gf_35' >
                        <div class='gform_body gform-body'><ul id='gform_fields_35' class='gform_fields top_label form_sublabel_below description_below'><li id="field_35_1"  class="gfield gfield_contains_required field_sublabel_below field_description_below gfield_visibility_visible"  data-js-reload="field_35_1"><label class='gfield_label' for='input_35_1' >Subscribe<span class="gfield_required"><span class="gfield_required gfield_required_asterisk">*</span></span></label><div class='ginput_container ginput_container_email'>
                            <input name='input_1' id='input_35_1' type='text' value='' class='medium' tabindex='1'   aria-required="true" aria-invalid="false"  />
                        </div></li></ul></div>
        <div class='gform_footer top_label'> <input type='submit' id='gform_submit_button_35' class='gform_button button' value='Submit' tabindex='2' onclick='if(window["gf_submitting_35"]){return false;}  window["gf_submitting_35"]=true;  ' onkeypress='if( event.keyCode == 13 ){ if(window["gf_submitting_35"]){return false;} window["gf_submitting_35"]=true;  jQuery("#gform_35").trigger("submit",[true]); }' /> <input type='hidden' name='gform_ajax' value='form_id=35&amp;title=&amp;description=&amp;tabindex=1' />
            <input type='hidden' class='gform_hidden' name='is_submit_35' value='1' />
            <input type='hidden' class='gform_hidden' name='gform_submit' value='35' />
            
            <input type='hidden' class='gform_hidden' name='gform_unique_id' value='' />
            <input type='hidden' class='gform_hidden' name='state_35' value='WyJbXSIsImMwZWNiYWMwM2FhMGU4ODJkNGZlZTRmYzc3MjhmMDBmIl0=' />
            <input type='hidden' class='gform_hidden' name='gform_target_page_number_35' id='gform_target_page_number_35' value='0' />
            <input type='hidden' class='gform_hidden' name='gform_source_page_number_35' id='gform_source_page_number_35' value='1' />
            <input type='hidden' name='gform_field_values' value='' />
            
        </div>
                        <p style="display: none !important;"><label>&#916;<textarea name="ak_hp_textarea" cols="45" rows="8" maxlength="100"></textarea></label><input type="hidden" id="ak_js_2" name="ak_js" value="204"/><script>document.getElementById( "ak_js_2" ).setAttribute( "value", ( new Date() ).getTime() );</script></p></form>
                        </div>
                <iframe style='display:none;width:0px;height:0px;' src='about:blank' name='gform_ajax_frame_35' id='gform_ajax_frame_35' title='This iframe contains the logic required to handle Ajax powered Gravity Forms.'></iframe>
                <script>
gform.initializeOnLoaded( function() {gformInitSpinner( 35, 'https://www.brentozar.com/wp-content/plugins/gravityforms/images/spinner.svg' );jQuery('#gform_ajax_frame_35').on('load',function(){var contents = jQuery(this).contents().find('*').html();var is_postback = contents.indexOf('GF_AJAX_POSTBACK') >= 0;if(!is_postback){return;}var form_content = jQuery(this).contents().find('#gform_wrapper_35');var is_confirmation = jQuery(this).contents().find('#gform_confirmation_wrapper_35').length > 0;var is_redirect = contents.indexOf('gformRedirect(){') >= 0;var is_form = form_content.length > 0 && ! is_redirect && ! is_confirmation;var mt = parseInt(jQuery('html').css('margin-top'), 10) + parseInt(jQuery('body').css('margin-top'), 10) + 100;if(is_form){jQuery('#gform_wrapper_35').html(form_content.html());if(form_content.hasClass('gform_validation_error')){jQuery('#gform_wrapper_35').addClass('gform_validation_error');} else {jQuery('#gform_wrapper_35').removeClass('gform_validation_error');}setTimeout( function() { /* delay the scroll by 50 milliseconds to fix a bug in chrome */ jQuery(document).scrollTop(jQuery('#gform_wrapper_35').offset().top - mt); }, 50 );if(window['gformInitDatepicker']) {gformInitDatepicker();}if(window['gformInitPriceFields']) {gformInitPriceFields();}var current_page = jQuery('#gform_source_page_number_35').val();gformInitSpinner( 35, 'https://www.brentozar.com/wp-content/plugins/gravityforms/images/spinner.svg' );jQuery(document).trigger('gform_page_loaded', [35, current_page]);window['gf_submitting_35'] = false;}else if(!is_redirect){var confirmation_content = jQuery(this).contents().find('.GF_AJAX_POSTBACK').html();if(!confirmation_content){confirmation_content = contents;}setTimeout(function(){jQuery('#gform_wrapper_35').replaceWith(confirmation_content);jQuery(document).scrollTop(jQuery('#gf_35').offset().top - mt);jQuery(document).trigger('gform_confirmation_loaded', [35]);window['gf_submitting_35'] = false;wp.a11y.speak(jQuery('#gform_confirmation_message_35').text());}, 50);}else{jQuery('#gform_35').append(contents);if(window['gformRedirect']) {gformRedirect();}}jQuery(document).trigger('gform_post_render', [35, current_page]);} );} );
</script>
</div></div></div></div></section></main>

</div>
	<footer id="page-footer" class="l-footer" itemscope itemtype="https://schema.org/WPFooter">
		<section class="l-section wpb_row align_center_xs height_small color_footer-bottom"><div class="l-section-h i-cf"><div class="g-cols vc_row via_flex valign_top type_default stacking_default">
<div class="vc_col-sm-6 wpb_column vc_column_container"><div class="vc_column-inner"><div class="wpb_wrapper"><div class="wpb_text_column"><div class="wpb_wrapper"><p>© Brent Ozar Unlimited®. All Rights Reserved.<br />
<a href="https://www.brentozar.com/privacy-policy/">Privacy Policy</a> &#8211; <a href="https://www.brentozar.com/training/refund-and-cancellation-policy-for-training/">Terms and Conditions</a></p>
</div></div></div></div></div>
<div class="vc_col-sm-6 wpb_column vc_column_container"><div class="vc_column-inner"><div class="wpb_wrapper"><div class="w-menu layout_hor style_links align_right us_menu_1" style="--main-gap:1.5rem;--main-ver-indent:0.8em;--main-hor-indent:0.8em;"><ul id="menu-2016-08-menu-1" class="menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-25018"><a href="https://www.brentozar.com/sql-critical-care/">Consulting</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-343691"><a href="https://training.brentozar.com">Training</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-112833"><a href="https://www.brentozar.com/sql-constantcare/">Monitoring</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-25024"><a href="https://www.brentozar.com/first-aid/">Scripts</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-25025"><a href="https://www.brentozar.com/blog/">Blog</a></li></ul><style>@media ( max-width:600px ){.us_menu_1 .menu{display:block!important}.us_menu_1 .menu>li{margin:0 0 var(--main-gap,1.5rem)!important}}</style></div></div></div></div>
</div></div></section>
	</footer>
	<a class="w-toplink pos_right" href="#" title="Back to top" aria-label="Back to top"><span></span></a>	<button id="w-header-show" class="w-header-show" aria-label="Menu"><span>Menu</span></button>
	<div class="w-header-overlay"></div>
		<script>
		// Store some global theme options used in JS
		if ( window.$us === undefined ) {
			window.$us = {};
		}
		$us.canvasOptions = ( $us.canvasOptions || {} );
		$us.canvasOptions.disableEffectsWidth = 900;
		$us.canvasOptions.columnsStackingWidth = 768;
		$us.canvasOptions.backToTopDisplay = 100;
		$us.canvasOptions.scrollDuration = 1000;

		$us.langOptions = ( $us.langOptions || {} );
		$us.langOptions.magnificPopup = ( $us.langOptions.magnificPopup || {} );
		$us.langOptions.magnificPopup.tPrev = 'Previous (Left arrow key)';
		$us.langOptions.magnificPopup.tNext = 'Next (Right arrow key)';
		$us.langOptions.magnificPopup.tCounter = '%curr% of %total%';

		$us.navOptions = ( $us.navOptions || {} );
		$us.navOptions.mobileWidth = 900;
		$us.navOptions.togglable = true;
		$us.ajaxLoadJs = true;
		$us.templateDirectoryUri = 'https://www.brentozar.com/wp-content/themes/Impreza';
	</script>
	<script>if ( window.$us === undefined ) window.$us = {};$us.headerSettings = {"default":{"options":{"breakpoint":"900","orientation":"hor","sticky":true,"sticky_auto_hide":false,"scroll_breakpoint":"100","transparent":"0","width":"300px","elm_align":"center","shadow":"thin","top_show":"1","top_height":"36px","top_sticky_height":"36px","top_fullwidth":"0","top_centering":"","middle_height":"100px","middle_sticky_height":"60px","middle_fullwidth":"1","middle_centering":"","elm_valign":"top","bg_img":"25121|full","bg_img_wrapper_start":"","bg_img_size":"cover","bg_img_repeat":"repeat","bg_img_position":"top center","bg_img_attachment":"1","bg_img_wrapper_end":"","bottom_show":"0","bottom_height":"50px","bottom_sticky_height":"50px","bottom_fullwidth":"0","bottom_centering":"","bgimage_wrapper_end":"","top_transparent_text_hover_color":"_header_transparent_text_hover","bottom_bg_color":"#ffffff","bottom_text_hover_color":"#ef4135","bottom_text_color":"#777777"},"layout":{"top_left":[],"top_center":[],"top_right":["search:1","menu:2","cart:1","socials:1"],"middle_left":["image:1"],"middle_center":["menu:1"],"middle_right":[],"bottom_left":[],"bottom_center":[],"bottom_right":[],"hidden":[]}},"tablets":{"options":{"breakpoint":"901","orientation":"hor","sticky":true,"sticky_auto_hide":false,"scroll_breakpoint":"100","transparent":"0","width":"300px","elm_align":"center","shadow":"thin","top_show":"0","top_height":"36px","top_sticky_height":"36px","top_fullwidth":"0","top_centering":"","middle_height":"80px","middle_sticky_height":"50px","middle_fullwidth":"1","middle_centering":"","elm_valign":"top","bg_img":"25121|full","bg_img_wrapper_start":"","bg_img_size":"cover","bg_img_repeat":"repeat","bg_img_position":"top center","bg_img_attachment":"1","bg_img_wrapper_end":"","bottom_show":"0","bottom_height":"50px","bottom_sticky_height":"50px","bottom_fullwidth":"0","bottom_centering":"","bgimage_wrapper_end":""},"layout":{"top_left":[],"top_center":[],"top_right":["menu:2","cart:1"],"middle_left":["image:1"],"middle_center":["menu:1"],"middle_right":["socials:1","search:1"],"bottom_left":[],"bottom_center":[],"bottom_right":[],"hidden":[]}},"mobiles":{"options":{"breakpoint":"601","orientation":"hor","sticky":true,"sticky_auto_hide":false,"scroll_breakpoint":"50","transparent":"0","width":"300px","elm_align":"center","shadow":"thin","top_show":"1","top_height":"36px","top_sticky_height":"0px","top_fullwidth":"0","top_centering":"","middle_height":"50px","middle_sticky_height":"60px","middle_fullwidth":"1","middle_centering":"","elm_valign":"top","bg_img":"","bg_img_wrapper_start":"","bg_img_size":"cover","bg_img_repeat":"repeat","bg_img_position":"top center","bg_img_attachment":"1","bg_img_wrapper_end":"","bottom_show":"0","bottom_height":"50px","bottom_sticky_height":"50px","bottom_fullwidth":"0","bottom_centering":"","bgimage_wrapper_end":""},"layout":{"top_left":[],"top_center":["socials:1"],"top_right":["menu:2","cart:1"],"middle_left":["image:1"],"middle_center":["menu:1"],"middle_right":["menu:1","search:1"],"bottom_left":[],"bottom_center":[],"bottom_right":[],"hidden":[]}},"header_id":75990,"laptops":{"options":{"breakpoint":"901","orientation":"hor","sticky":true,"sticky_auto_hide":false,"scroll_breakpoint":"100","transparent":"0","width":"300px","elm_align":"center","shadow":"thin","top_show":"1","top_height":"36px","top_sticky_height":"36px","top_fullwidth":"0","top_centering":"","middle_height":"100px","middle_sticky_height":"60px","middle_fullwidth":"1","middle_centering":"","elm_valign":"top","bg_img":"25121|full","bg_img_wrapper_start":"","bg_img_size":"cover","bg_img_repeat":"repeat","bg_img_position":"top center","bg_img_attachment":"1","bg_img_wrapper_end":"","bottom_show":"0","bottom_height":"50px","bottom_sticky_height":"50px","bottom_fullwidth":"0","bottom_centering":"","bgimage_wrapper_end":"","custom_breakpoint":1},"layout":{"top_left":[],"top_center":[],"top_right":["search:1","menu:2","cart:1","socials:1"],"middle_left":["image:1"],"middle_center":["menu:1"],"middle_right":[],"bottom_left":[],"bottom_center":[],"bottom_right":[],"hidden":[]}}};</script><div class="add-cart-email-wrapper" style="display: none;">
<div class="metorik-add-cart-email-form">
    <!-- Title of the popup -->
    <h3>Save your cart?</h3>

    <!-- Close button -->
    <div class="close-button">x</div>

    <!-- Email input wrapper - it's recommended to keep this markup as-is so loading icons can automatically be added -->
    <div class="email-input-wrapper">
        <!-- Don't change the 'email-input' class on this input - used for saving email -->
        <input type="text" placeholder="Your email" class="email-input" />
    </div>

    <!-- Email usage notice if enabled -->
    </div></div><div id='pys_ajax_events'></div>        <script>
            var node = document.getElementsByClassName('woocommerce-message')[0];
            if(node && document.getElementById('pys_late_event')) {
                var messageText = node.textContent.trim();
                if(!messageText) {
                    node.style.display = 'none';
                }
            }
        </script>
            <noscript><img height="1" width="1" style="display: none;" src="https://www.facebook.com/tr?id=277915446177659&ev=PageView&noscript=1&eid=277915446177659&cd%5Bpost_category%5D=Columnstore+Indexes&cd%5Bpage_title%5D=Columnstore+Indexes+are+Finally+Sorted+in+SQL+Server+2022.&cd%5Bpost_type%5D=post&cd%5Bpost_id%5D=348666&cd%5Bplugin%5D=PixelYourSite&cd%5Bevent_url%5D=www.brentozar.com%2Farchive%2F2022%2F07%2Fcolumnstore-indexes-are-finally-sorted-in-sql-server-2022%2F&cd%5Buser_role%5D=guest" alt="facebook_pixel"></noscript>
	<script type="text/javascript">
		(function () {
			var c = document.body.className;
			c = c.replace(/woocommerce-no-js/, 'woocommerce-js');
			document.body.className = c;
		})();
	</script>
	<link rel='stylesheet' id='urvanov_syntax_highlighter-css'  href='https://www.brentozar.com/wp-content/plugins/urvanov-syntax-highlighter/css/min/urvanov_syntax_highlighter.min.css?ver=2.8.27' media='all' />
<script src='https://www.brentozar.com/wp-content/plugins/woocommerce/assets/js/selectWoo/selectWoo.full.min.js?ver=1.0.9-wc.6.7.0' id='selectWoo-js'></script>
<script id='wc-memberships-blocks-common-js-extra'>
var wc_memberships_blocks_common = {"keywords":{"email":"Email","phone":"Phone","plan":"Plan","address":"Address","search_not_found":"We didn\u2019t find any members. Please try a different search or check for typos.","results_not_found":"No records found..."},"ajaxUrl":"https:\/\/www.brentozar.com\/wp-admin\/admin-ajax.php","restUrl":"https:\/\/www.brentozar.com\/wp-json\/","restNonce":"5da895af09"};
</script>
<script src='https://www.brentozar.com/wp-content/plugins/woocommerce-memberships/assets/js/frontend/wc-memberships-blocks-common.min.js?ver=1.23.0' id='wc-memberships-blocks-common-js'></script>
<script src='https://www.brentozar.com/wp-content/plugins/woocommerce/assets/js/jquery-blockui/jquery.blockUI.min.js?ver=2.7.0-wc.6.7.0' id='jquery-blockui-js'></script>
<script id='wc-add-to-cart-js-extra'>
var wc_add_to_cart_params = {"ajax_url":"\/wp-admin\/admin-ajax.php","wc_ajax_url":"\/?wc-ajax=%%endpoint%%","i18n_view_cart":"View cart","cart_url":"https:\/\/www.brentozar.com\/cart\/","is_cart":"","cart_redirect_after_add":"no"};
</script>
<script src='https://www.brentozar.com/wp-content/plugins/woocommerce/assets/js/frontend/add-to-cart.min.js?ver=6.7.0' id='wc-add-to-cart-js'></script>
<script id='woocommerce-js-extra'>
var woocommerce_params = {"ajax_url":"\/wp-admin\/admin-ajax.php","wc_ajax_url":"\/?wc-ajax=%%endpoint%%"};
</script>
<script src='https://www.brentozar.com/wp-content/plugins/woocommerce/assets/js/frontend/woocommerce.min.js?ver=6.7.0' id='woocommerce-js'></script>
<script id='wc-cart-fragments-js-extra'>
var wc_cart_fragments_params = {"ajax_url":"\/wp-admin\/admin-ajax.php","wc_ajax_url":"\/?wc-ajax=%%endpoint%%","cart_hash_key":"wc_cart_hash_832de848ca6f50dc08e5994a610e45c9","fragment_name":"wc_fragments_832de848ca6f50dc08e5994a610e45c9","request_timeout":"5000"};
</script>
<script id='metorik-js-js-extra'>
var metorik_params = {"lifetime":"6","session":"30","ajaxurl":"https:\/\/www.brentozar.com\/wp-admin\/admin-ajax.php","cart_tracking":"1","cart_items":"0","cart_checkout_button":"1","add_cart_popup_placement":"bottom","send_cart_events":"added_to_cart removed_from_cart updated_cart_totals updated_shipping_method applied_coupon removed_coupon updated_checkout"};
</script>
<script src='https://www.brentozar.com/wp-content/plugins/metorik-helper/assets/js/metorik.min.js?ver=1.5.2' id='metorik-js-js'></script>
<script src='https://www.brentozar.com/wp-content/uploads/us-assets/www.brentozar.com.js?ver=352fde32' id='us-core-js'></script>
<script id='urvanov_syntax_highlighter_js-js-extra'>
var UrvanovSyntaxHighlighterSyntaxSettings = {"version":"2.8.27","is_admin":"0","ajaxurl":"https:\/\/www.brentozar.com\/wp-admin\/admin-ajax.php","prefix":"urvanov-syntax-highlighter-","setting":"urvanov-syntax-highlighter-setting","selected":"urvanov-syntax-highlighter-setting-selected","changed":"urvanov-syntax-highlighter-setting-changed","special":"urvanov-syntax-highlighter-setting-special","orig_value":"data-orig-value","debug":""};
var UrvanovSyntaxHighlighterSyntaxStrings = {"copy":"Copied to the clipboard","minimize":"Click To Expand Code"};
</script>
<script src='https://www.brentozar.com/wp-content/plugins/urvanov-syntax-highlighter/js/min/urvanov_syntax_highlighter.min.js?ver=2.8.27' id='urvanov_syntax_highlighter_js-js'></script>
<script src='https://www.brentozar.com/wp-includes/js/comment-reply.min.js?ver=6.0.1' id='comment-reply-js'></script>
<script>
gform.initializeOnLoaded( function() { jQuery(document).on('gform_post_render', function(event, formId, currentPage){if(formId == 35) {} } );jQuery(document).bind('gform_post_conditional_logic', function(event, formId, fields, isInit){} ) } );
</script>
<script>
gform.initializeOnLoaded( function() { jQuery(document).trigger('gform_post_render', [35, 1]) } );
</script>
</body>
</html>
